Bug 121435 - Fatal errors in sv.po of system-config-mouse
Fatal errors in sv.po of system-config-mouse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-mouse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 11:32 EDT by Christian Rose
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 11:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2004-04-21 11:32:39 EDT
Göran Uddeborg recently pointed out to me that the sv.po of
system-config-mouse / redhat-config-mouse contained fatal errors; to
be precise duplicated messages. Such fatal errors will result in the
.mo file not being generated at build time and hence ruin the entire
translation for the affected language.

Upon closer inspection, it looks like this commit was the one causing
the problem:

        $Id: sv.po,v 1.23 2004/03/22 20:41:13 bfox Exp $

From the looks of the diff for this commit, it seems like someone
automatically searched-and-replaced the name "redhat-config-mouse"
with "system-config-mouse" throughout the entire po file.

As there were already two sets of messages stored in the po file, i.e.

#~ msgid "Run 'redhat-config-mouse --help' to see a list of mice"
#~ msgstr "Kör \"redhat-config-mouse --help\" för att se en lista med 

#~ msgid "Run 'system-config-mouse --help' to see a list of mice"
#~ msgstr "Kör \"system-config-mouse --help\" för att se en lista med
möss"

only differing in the application name, the blind search-and-replace
(without subsequent error checking) did create two sets of identical
messages and hence fatal errors.

I tried to resolve the issue myself now in CVS, but translators seem
to be unable to commit to CVS right now (see
http://www.redhat.com/archives/fedora-trans-list/2004-April/msg00100.html).
Comment 1 Brent Fox 2004-04-21 11:49:37 EDT
Fixed in system-config-mouse 1.2.6-2.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.