Bug 1214502 - RFE: Grant project creation permission to certain sets of users
RFE: Grant project creation permission to certain sets of users
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: 3.8
Assigned To: Alex Eng
Damian Jansen
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-22 17:37 EDT by stephane
Modified: 2016-01-20 20:40 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.8.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3941)
Doc Type: Bug Fix
Doc Text:
Story Points: 1
Clone Of:
Environment:
Last Closed: 2016-01-20 20:40:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stephane 2015-04-22 17:37:53 EDT
Description of problem:

We would like to allow everyone who has an OpenID account with us to create an account on Zanata and translate. However, we don't necessarily want everyone to be able to create a project since we will have a pre-defined group of projects that users can contribute to. It would be great if we could limit project creation to specific role(s).
Comment 1 Luke Brooker 2015-04-22 23:24:02 EDT
This is definitely something we would like to do, at least on an organisation level, once that is implemented.

On an instance level, we probably should restructure/clean up how we do permissions when we add Organisations. How exactly that looks, we will need to work out.

I'll keep this bug updated when we know more.

Not sure what priority we can make this right now.
Comment 2 Sean Flanigan 2015-04-27 21:30:23 EDT
Creating projects was originally restricted to the admin role, but then opened up to all users.  We obviously should have taken the middle ground.  I think we just need to define a role which can create projects, for instance "projectcreator", and then it will be up to each server whether this role is inherited by all users or assigned individually.
Comment 3 Michelle Kim 2015-05-05 18:59:11 EDT
It seems creating a new role who can create projects  (similar to reviewer roles who can review translation) might be a solution for current instances. For the external instances, we wanted to give more opportunities for any users to test out Zanata by creating their own projects but also this might have created many rubbish projects. 

I will take this as next priority items to discuss for implementation details.
Comment 4 Carlos Munoz 2015-06-28 20:31:47 EDT
Sean, your solution sounds pretty straightforward. I'm assigning to you for preliminary assessment (if there's anything else to add). We should schedule this for our next sprint.
Comment 5 David Mason 2015-07-08 00:26:20 EDT
 - add role 'projectcreator'
 - by default, make the user role include/inherit projectcreator
   - admin can disable this on instances where this is wanted
Comment 6 Alex Eng 2015-07-08 18:12:13 EDT
Pull request:
https://github.com/zanata/zanata-server/pull/902
Comment 7 Damian Jansen 2015-07-09 00:26:22 EDT
Verified at 3e8da24ecd73683fd1cc8713d1e80cf2c61fcc07
Comment 8 Damian Jansen 2015-07-21 00:09:15 EDT
Verified merge at 7e90a9b74ecb888710e67bbd0a87d4058e00699a

Note You need to log in before you can comment on or make changes to this bug.