Bug 121461 - system-config-display does not recognize radeon 9600xt
system-config-display does not recognize radeon 9600xt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 16:01 EDT by István Tóth
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.37-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 15:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description István Tóth 2004-04-21 16:01:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
System-config-display detects my Readon 9600XT as a VESA card.
Since The X.org X server handles the card perfectly, ( If I choose the
"radeon" driver manually), the config utility should select the radeon
driver for this card.

I encountered the probelm during install (i.e the installer chose the
VESA driver, bt I presume that it also uses system-config-display
database)

Version-Release number of selected component (if applicable):
system-config-display-1.0.13-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 test
2.
3.
    

Actual Results:  X.org was using the VESA driver

Expected Results:  X.org should have used the radeon driver

Additional info:

[stoty@Vigor10 stoty]$ /sbin/lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host &
Memory & AGP Controller
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual
PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL
Media IO] (rev 10)
00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
(rev d0)
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738
(rev 10)
00:09.0 Ethernet controller: 3Com Corporation 3cSOHO100-TX Hurricane
(rev 30)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AR
[Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon
9600] (Secondary)

[stoty@Vigor10 stoty]$ /sbin/lspci -n
00:00.0 Class 0600: 1039:0646
00:01.0 Class 0604: 1039:0001
00:02.0 Class 0601: 1039:0961 (rev 10)
00:02.1 Class 0c05: 1039:0016
00:02.2 Class 0c03: 1039:7001 (rev 07)
00:02.3 Class 0c03: 1039:7001 (rev 07)
00:02.5 Class 0101: 1039:5513 (rev d0)
00:05.0 Class 0401: 13f6:0111 (rev 10)
00:09.0 Class 0200: 10b7:7646 (rev 30)
01:00.0 Class 0300: 1002:4152
01:00.1 Class 0380: 1002:4172
Comment 1 Paul Nasrat 2004-08-09 09:40:47 EDT
Please confirm if the issue is still present with FC3T1 for detecting
your card.
Comment 2 Adam Jackson 2006-03-22 15:23:59 EST
Should be working in FC5.  Please reopen if this is still an issue for you after
upgrading.

Note You need to log in before you can comment on or make changes to this bug.