Bug 121473 - I can no longer use a samba share after upgrading.
I can no longer use a samba share after upgrading.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 18:08 EDT by Mark Lane
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 19:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Lane 2004-04-21 18:08:27 EDT
Description of problem:
I upgraded my system to the newest devel packages and after a reboot.
I can no longer access a samba share I had been using. 

Here's the log from the samba server

[root@srv root]# tail /var/log/samba/log.192.168.60.99
[2004/04/21 15:54:35, 3] auth/auth.c:check_ntlm_password(222)
  check_ntlm_password:  mapped user is: [SRV]\[mark]@[192.168.60.99]
[2004/04/21 15:54:35, 3] auth/auth.c:check_ntlm_password(268)
  check_ntlm_password: sam authentication for user [mark] succeeded
[2004/04/21 15:54:35, 2] auth/auth.c:check_ntlm_password(305)
  check_ntlm_password:  authentication for user [mark] -> [mark] ->
[mark] succeeded
[2004/04/21 15:54:35, 1] smbd/service.c:make_connection_snum(705)
  192.168.60.99 (192.168.60.99) connect to service common initially as
user mark (uid=508, gid=1000) (pid 4329)
[2004/04/21 15:54:35, 1] smbd/service.c:close_cnum(887)
  192.168.60.99 (192.168.60.99) closed connection to service common

It appears that the connection close right after openning.

Version-Release number of selected component (if applicable):

samba-3.0.3-2.pre2
samba-common-3.0.3-2.pre2
samba-client-3.0.3-2.pre2


How reproducible:
Every reboot

Steps to Reproduce:
1. upgraded samba and rebooted

  
Actual results:
logs into samba server and connection closes right away.

Expected results:
logs into samba server and connection remains open.

Additional info:
Comment 1 Leonard den Ottolander 2004-06-10 10:56:07 EDT
Could it be this is a security=share share? If so see bug 121503. You
forgot to mention any details on your configuration.
Comment 2 Mark Lane 2004-06-10 12:09:39 EDT
No I didn't update the samba server. I updated the client and I am 
using passwords anyway. Though I have seen the security=share error 
in another case. 
 
Athlon64 with VIA Chipset. Custom Kernel and it's running devel 
packages. 1GB of RAM 
Comment 3 Mark 2006-08-09 01:28:42 EDT
Looks like its a Fedora packaging error. I thought it was a Samba bug, and
started the https://bugzilla.samba.org/show_bug.cgi?id=4004 bug report.

To cut a long story short, this is what was said by a Samba-bugs expert:
"This is a fedora packaging error.  Their 3.0.23a package
is linked against cups 1.1 but they upgrades to cups 1.2."

I actually have 2 problems now (on separate machines both FC5):

1) a samba service which initialises but doesnt allow access from a win machine
anymore (no congfis changed)

2) a samba service which fails to initialise, smbd fails while nmbd works ok...
as always no configs changed

To be more precise, i updated samba through yumex...
Comment 4 Leonard den Ottolander 2006-08-09 10:06:55 EDT
Comment #3: This must be a different issue. Reported issue is against FC2-devel.
Report your (new) issues in new bug reports. One report per issue please.

Regarding the initial report: Was this issue fixed in FC2 or later? I suppose
this report should be closed as it's against a release that is no longer
supported. If the issue still exists it should be reported again.
Comment 5 Simo Sorce 2007-03-23 19:03:39 EDT
Close this bug as it is against an unsupported old version. The bug should be
fixed in Fc5/FC6, please open a new bug if not.

Note You need to log in before you can comment on or make changes to this bug.