Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 121474 - RFE: add libidn package
RFE: add libidn package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
Blocks: 117706
  Show dependency treegraph
 
Reported: 2004-04-21 18:21 EDT by Nalin Dahyabhai
Modified: 2014-03-16 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 16:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2004-04-21 18:21:55 EDT
See http://www.gnu.org/software/libidn/, apparently a prerequisite for
#117706.
Comment 1 Bill Nottingham 2004-04-21 18:28:11 EDT
Gah, that patch that gets the encoding within jwhois just looks *wrong*.

Aside from that, interesting. I'd be curious to see the libc authors
opinions on integrating that into libc for getaddrinfo()
Comment 2 Robert Scheck 2004-07-11 17:43:01 EDT
IDN support is integrated (using Simon Josefsson's GNU libidn) to
glibc 2.3.3 - FC2/3 already have working IDN support (tested).

The package "libidn" is in Fedora Development also available.

Bill, I know that this encoding hack is just wrong, it's removed now
and the patch is updated, because DENIC allows querying for ace domains 
also, yet :-)
Comment 3 Bill Nottingham 2004-07-12 16:29:42 EDT
Closing as fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.