Bug 1214807 - "Malformed yum output" message when doing "dnf migrate"
"Malformed yum output" message when doing "dnf migrate"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
: 1218345 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-23 10:56 EDT by Mat Booth
Modified: 2015-05-30 11:56 EDT (History)
12 users (show)

See Also:
Fixed In Version: dnf-plugins-extras-0.0.8-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-30 11:56:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mat Booth 2015-04-23 10:56:41 EDT
Description of problem:

After upgrading to the latest F22, prompted by the yum deprecation message, I decided to "dnf migrate" as suggested by the message. This resulted in the error message "Error: Malformed yum output" as shown below. 

Version-Release number of selected component:

[mbooth@fedora22 ~]$ rpm -qa | grep "\(yum\|dnf\)" |sort
dnf-0.6.5-1.fc22.noarch
dnf-conf-0.6.5-1.fc22.noarch
dnf-yum-0.6.5-1.fc22.noarch
python3-dnf-0.6.5-1.fc22.noarch
python3-dnf-plugins-core-0.1.6-3.fc22.noarch
python-dnf-0.6.5-1.fc22.noarch
python-dnf-plugins-core-0.1.6-3.fc22.noarch
python-dnf-plugins-extras-common-0.0.7-1.fc22.noarch
python-dnf-plugins-extras-migrate-0.0.7-1.fc22.noarch
yum-3.4.3-505.fc22.noarch
yum-langpacks-0.4.5-1.fc22.noarch
yum-metadata-parser-1.1.4-14.fc22.x86_64
yum-utils-1.1.31-505.fc22.noarch

Actual result:

[mbooth@fedora22 ~]$ sudo dnf migrate
Using metadata from Thu Apr 23 12:26:20 2015 (1:08:38 hours old)
Migrating history data...
Migrating YUMDB data...
Loaded plugins: langpacks
checksum_type of koji-1.9.0-10.fc22.gitcd45e886.noarch not found
checksum_data of koji-1.9.0-10.fc22.gitcd45e886.noarch not found
checksum_type of python-cffi-0.8.6-1.fc22.x86_64 not found
checksum_data of python-cffi-0.8.6-1.fc22.x86_64 not found
checksum_type of python-krbV-1.0.90-9.fc22.x86_64 not found
checksum_data of python-krbV-1.0.90-9.fc22.x86_64 not found
checksum_type of python-pycparser-2.10-1.fc22.noarch not found
checksum_data of python-pycparser-2.10-1.fc22.noarch not found
checksum_type of python-ply-3.4-7.fc21.noarch not found
checksum_data of python-ply-3.4-7.fc21.noarch not found
checksum_type of pyOpenSSL-0.14-3.fc22.noarch not found
checksum_data of pyOpenSSL-0.14-3.fc22.noarch not found
1680 YUMDB records found, 1680 migrated, 0 skipped/preserved
Migrating groups data...
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Warning: no environments/groups match: installed
Error: Malformed yum output
Comment 1 Honza Silhan 2015-04-24 05:55:25 EDT
Thanks for the report, thats migration of groups bug. I will take a look.

Mat, can you share the original Fedora release you did your last clean install on the system? Do you have set `group_command` in yum.conf `cat /etc/yum.conf | grep group_command`? Your locale is `en_US.utf8`, right? Thanks in advance.
Comment 2 Mat Booth 2015-04-24 07:40:12 EDT
(In reply to Jan Silhan from comment #1)
> Thanks for the report, thats migration of groups bug. I will take a look.
> 
> Mat, can you share the original Fedora release you did your last clean
> install on the system? Do you have set `group_command` in yum.conf `cat
> /etc/yum.conf | grep group_command`? Your locale is `en_US.utf8`, right?
> Thanks in advance.


No, my locale is en_GB.UTF-8 (i.e., British)

cat /etc/yum.conf | grep group yields nothing -- there is no group_command set

And this system started as F21 and was upgraded to F22 alpha and then F22 beta.
Comment 3 Honza Silhan 2015-04-24 08:07:27 EDT
Thanks for reply and one more question: Whats the output of `yum group list installed`?.
Comment 4 Honza Silhan 2015-04-24 08:41:03 EDT
* I mean the output of real yum - /usr/bin/yum-deprecated or /usr/bin/yum if the former does not exist.
Comment 5 Mat Booth 2015-04-24 08:57:24 EDT
Sure thing:

[mbooth@fedora22 ~]$ /usr/bin/yum-deprecated group list installed
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Loaded plugins: langpacks
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Warning: no environments/groups match: installed
Comment 6 Honza Silhan 2015-04-24 14:21:17 EDT
Then it probably means you (and Anaconda?) haven't installed any group by yum. It prints info message and the yum's output is not printed now.

PR: https://github.com/rpm-software-management/dnf-plugins-extras/pull/26
Comment 7 Christian Stadelmann 2015-05-07 17:09:00 EDT
I think this fix is incomplete. In my case only one single group (LibreOffice) is installed. Still dnf migrate tells me the "Malformed yum output" error message. See Bug #1218345 Comment #5 for details.
Comment 8 Honza Silhan 2015-05-18 07:58:43 EDT
*** Bug 1218345 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2015-05-22 13:26:34 EDT
dnf-plugins-extras-0.0.8-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.8-1.fc22
Comment 10 Fedora Update System 2015-05-25 23:15:01 EDT
Package dnf-plugins-extras-0.0.8-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.8-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8740/dnf-plugins-extras-0.0.8-1.fc22
then log in and leave karma (feedback).
Comment 11 Sean Richards 2015-05-27 18:25:18 EDT
I can't seem to pull that update.  I've tried several times.  It tells me no match.  Anyone I can manually update the file?
Comment 12 Fedora Update System 2015-05-30 11:56:41 EDT
dnf-plugins-extras-0.0.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.