Bug 1214936 - After import of existing storage domain, VMs with two virtio-scsi disks will not boot
Summary: After import of existing storage domain, VMs with two virtio-scsi disks will ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Maor
QA Contact: lkuchlan
URL:
Whiteboard:
Depends On:
Blocks: 1215923
TreeView+ depends on / blocked
 
Reported: 2015-04-23 21:53 UTC by Jake Hunsaker
Modified: 2019-07-16 11:33 UTC (History)
11 users (show)

Fixed In Version: ovirt-engine-3.6.0_alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1215923 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:05:33 UTC
oVirt Team: Storage
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Jake Hunsaker 2015-04-23 21:53:19 UTC
Description of problem:

After importing a storage domain to a new RHEV-M, if a VM has two virtio-scsi disks attached, the VM will not boot. The console for the VM will fail with a "no bootable device" error.

Even if the second, non-OS, disk is deactivate and the VM is started with *just* the OS disk activated, the VM hits the same error.

Version-Release number of selected component (if applicable):
rhevm-3.5.0
RHEL 7 hypervisor
kernel-3.10.0-229.1.2.el7
vdsm 4.16.8.1-8.el7

How reproducible:
Always for this customer

Steps to Reproduce:
1. Import SD from Prod RHEV-M to DR
2. Import VMs
3. Try to start a VM with two virtio-scsi disks attached

Actual results:
VM does not boot

Expected results:
VM should boot

Additional info:

In testing this, the only common factor is that the VM(s) that have two virtio-scsi disks attached.

If a vm has two virtio disks or one virtio and one virtio-scsi the VM boots just fine. The issue only appears when both disks are virtio-scsi.

Further, in looking at the SPM the symlinks for the disks under the /rhev/data-center/... path are broken for the VMs that have two virtio-scsi disks.

Comment 3 Maor 2015-04-27 12:32:03 UTC
It looks this this is already solved as part of 
https://bugzilla.redhat.com/1197444 with patch https://gerrit.ovirt.org/#/c/38242/

Since this bug is modified, I'm moving this bug also to Modify

Comment 4 Allon Mureinik 2015-04-27 12:43:12 UTC
(In reply to Maor from comment #3)
> It looks this this is already solved as part of 
> https://bugzilla.redhat.com/1197444 with patch
> https://gerrit.ovirt.org/#/c/38242/
> 
> Since this bug is modified, I'm moving this bug also to Modify
Good!

Aharon/Yaniv - can you please provide acks so this bug can be cloned and verified properly.

Comment 6 lkuchlan 2015-06-07 10:54:39 UTC
Tested using:
ovirt-engine-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch
vdsm-4.17.0-822.git9b11a18.el7.noarch

Verification instructions:
1. Import SD from Prod RHEV-M to DR
2. Import VMs
3. Try to start a VM with two virtio-scsi disks attached

Results:
VM with two virtio-scsi disks is bootable

Comment 8 errata-xmlrpc 2016-03-09 21:05:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.