Bug 1214960 - instack-install-undercloud fails on RHEL 7.1 if python-six not installed
Summary: instack-install-undercloud fails on RHEL 7.1 if python-six not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-24 00:32 UTC by Dan Sneddon
Modified: 2015-08-05 13:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-04-24 00:32:54 UTC
Description of problem:
When running instack-install-undercloud on a fresh RHEL 7.1 bare metal server, it fails with "ImportError: No module named six". It succeeds if you run "sudo yum install -y python-six" first.

Version-Release number of selected component (if applicable):
instack.noarch                   0.0.6.4-g57c723a.el7.centos
instack-undercloud.noarch        2.0.0-dev1662.el7.centos @delorean-rdo-management


How reproducible:
100%

Steps to Reproduce:
1. Install RHEL 7.1 on bare metal
2. Follow sphinx instructions to install instack RPMs
3. Run "instack-install-indercloud"

Actual results:
instack-install-undercloud fails when it can't find the six module.

Expected results:
The instack installation scripts should complete.

Additional info:
Output of command, starting just before the error:

+ target_tag=10-install-git
+ date +%s.%N
+ output '10-install-git completed'
++ date
+ echo puppet-tuskar Fri Apr 24 02:09:22 CEST 2015 10-install-git completed
puppet-tuskar Fri Apr 24 02:09:22 CEST 2015 10-install-git completed
+ for target in '$targets'
+ output 'Running /tmp/tmpYtenhF/extra-data.d/10-merge-svc-map-files'
++ date
+ echo puppet-tuskar Fri Apr 24 02:09:22 CEST 2015 Running /tmp/tmpYtenhF/extra-data.d/10-merge-svc-map-files
puppet-tuskar Fri Apr 24 02:09:22 CEST 2015 Running /tmp/tmpYtenhF/extra-data.d/10-merge-svc-map-files
+ target_tag=10-merge-svc-map-files
+ date +%s.%N
+ /tmp/tmpYtenhF/extra-data.d/10-merge-svc-map-files
Traceback (most recent call last):
  File "/tmp/tmpYtenhF/extra-data.d/10-merge-svc-map-files", line 18, in <module>
    import six
ImportError: No module named six
INFO: 2015-04-24 02:09:22,703 -- ############### End stdout/stderr logging ###############
ERROR: 2015-04-24 02:09:22,703 --     Hook FAILED.
ERROR: 2015-04-24 02:09:22,703 -- Failed running command ['dib-run-parts', u'/tmp/tmpYtenhF/extra-data.d']
  File "/usr/lib/python2.7/site-packages/instack/main.py", line 153, in main
    em.run()
  File "/usr/lib/python2.7/site-packages/instack/runner.py", line 79, in run
    self.run_hook(hook)
  File "/usr/lib/python2.7/site-packages/instack/runner.py", line 174, in run_hook
    raise Exception("Failed running command %s" % command)
ERROR: 2015-04-24 02:09:22,704 -- None

Comment 5 Alexander Chuzhoy 2015-06-18 16:18:27 UTC
Verified:
Environment:
instack-undercloud-2.1.2-1.el7ost.noarch


The unified CLI command to install the undercloud is now:
openstack undercloud install

And the issue doesn't reproduce.

Comment 7 errata-xmlrpc 2015-08-05 13:51:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.