Bug 1215016 - Wrong import prevents configuration update after update from 6.5 to 6.6
Summary: Wrong import prevents configuration update after update from 6.5 to 6.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Chaofeng Wu
URL:
Whiteboard:
Depends On:
Blocks: 1219808
TreeView+ depends on / blocked
 
Reported: 2015-04-24 06:52 UTC by Pavel Zhukov
Modified: 2019-07-16 11:59 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Fixed a python file issue which prevented configuration migration from occuring when updating Red Hat Enterprise Virtualization Hypervisor from 6.5 to 6.6.
Clone Of:
: 1219808 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:27:36 UTC
oVirt Team: Node
Target Upstream Version:
mgoldboi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1213479 high CLOSED UnknownNicError("Unknown network interface: 'eth0'",) after hitting BZ 1197668 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 40201 master MERGED Fix wrong import name Never
oVirt gerrit 40617 ovirt-3.5 MERGED Fix wrong import name Never

Internal Links: 1213479

Description Pavel Zhukov 2015-04-24 06:52:17 UTC
Description of problem:
The failure is:
Config migration failed
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 68, in _run
    migration_func()
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 56, in
importConfigs
    ImportConfigs().translate_all()
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 91, in
translate_all
    self.migrate_network_layout()
  File "/usr/lib/python2.6/site-packages/ovirt/node/config/migrate.py", line 320, in
migrate_network_layout
    from ovirt.node import defaults
ImportError: cannot import name defaults

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor 6.6 (20150128.0.el6ev)


How reproducible:
100%

Additional info:
Looks like regression in https://gerrit.ovirt.org/#/c/27303/3/src/ovirt/node/config/migrate.py

Comment 1 Fabian Deutsch 2015-04-24 08:01:26 UTC
Thanks for the report and fix.

Comment 3 Pavel Zhukov 2015-04-24 12:23:43 UTC
Steps to reproduce:
Remove OVIRT_*VERSION parameter from the /etc/defaults/ovirt persist file and reboot the host
Exception appears in /var/log/ovirt.log

Comment 4 haiyang,dong 2015-05-06 02:26:35 UTC
I could reproduce this bug in the follow version:
rhev-hypervisor6-6.6-20150128.0.iso
ovirt-node-3.2.1-6.el6.noarch


Test steps:
1. Clean install rhev-hypervisor6-6.6-20150128.0.iso
2. Login rhevh and press F2 to enter into shell console
3. Remove OVIRT_*VERSION parameter from the /etc/defaults/ovirt
4. persist /etc/defaults/ovirt
5. Reboot rhevh and check log info in /var/log/ovirt.log

After step5, could see exception info in /var/log/ovirt.log

Comment 8 Chaofeng Wu 2015-11-12 15:48:57 UTC
According comment 4, verify this bug on build rhev-hypervisor7-7.2-20151104

Versions:
rhev-hypervisor7-7.2-20151104.0.iso
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Steps:
1. Install rhev-hypervisor7-7.2-20151104 and login rhevh
2. Press F2 drop into shell, remove the OVIRT_*VERSION parameter from the /etc/defaults/ovirt
3. Persist /etc/defaults/ovirt
4. Reboot system and check log in /var/log/ovirt.log

Result:
There is no python ImportError error in /var/log/ovirt.log

This bug has been fixed, so change the status to VERIFIED.

Comment 10 errata-xmlrpc 2016-03-09 14:27:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.