SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1215026 - Tracker bug for 3.7 Issues reported by Coverity static analysis tool -
Summary: Tracker bug for 3.7 Issues reported by Coverity static analysis tool -
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.7.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 789278 1352281
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-24 07:16 UTC by Humble Chirammal
Modified: 2016-07-03 10:37 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 789278
Environment:
Last Closed: 2016-04-19 07:12:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-04-24 07:45:49 UTC
REVIEW: http://review.gluster.org/10361 (features/trash: Minor coverity fixes) posted (#1) for review on release-3.7 by Anoop C S (achiraya@redhat.com)

Comment 2 Anand Avati 2015-04-26 08:55:50 UTC
REVIEW: http://review.gluster.org/10361 (features/trash: Minor coverity fixes) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 3 Anand Avati 2015-04-26 18:05:10 UTC
REVIEW: http://review.gluster.org/10361 (features/trash: Minor coverity fixes) posted (#3) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 4 Anand Avati 2015-04-27 06:25:33 UTC
COMMIT: http://review.gluster.org/10361 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit f2026fd6d5993fa5d57ccb7b0add832cef14e09c
Author: Anoop C S <achiraya@redhat.com>
Date:   Wed Apr 15 13:01:51 2015 +0530

    features/trash: Minor coverity fixes
    
            Backport of http://review.gluster.org/10315
    
    CID 1288784
    CID 1288785
    CID 1288795
    CID 1288796
    CID 1288797
    CID 1288802
    
    Change-Id: I51dd7653a2dce3b7b6387e5d91c1c07eb157a04b
    BUG: 1215026
    Signed-off-by: Anoop C S <achiraya@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/10361
    Tested-by: NetBSD Build System

Comment 5 Vijay Bellur 2016-04-13 06:25:29 UTC
REVIEW: http://review.gluster.org/13983 (glusterfsd: coverity fix) posted (#1) for review on release-3.7 by Sakshi Bansal

Comment 6 Vijay Bellur 2016-04-13 06:37:17 UTC
REVIEW: http://review.gluster.org/13984 (glusterd: coverity fix for insecure temporary file) posted (#1) for review on release-3.7 by Sakshi Bansal

Comment 7 Vijay Bellur 2016-04-15 04:26:41 UTC
REVIEW: http://review.gluster.org/14003 (libglusterfs: coverity fix) posted (#1) for review on release-3.7 by Sakshi Bansal

Comment 8 Vijay Bellur 2016-04-15 14:25:15 UTC
COMMIT: http://review.gluster.org/13984 committed in release-3.7 by Jeff Darcy (jdarcy@redhat.com) 
------
commit 96a246a8944cfd9154a75e7dc66fc9aacc39dbf3
Author: Sakshi <sabansal@redhat.com>
Date:   Wed Apr 15 15:30:51 2015 +0530

    glusterd: coverity fix for insecure temporary file
    
    Set umask before creating temporary file
    
    Backport of http://review.gluster.org/9558
    
    > Change-Id: Ia39af63b05ce68f3f3af6585b70d4129a5530269
    > BUG: 789278
    > Signed-off-by: Sakshi <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/9558
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    Change-Id: Ia39af63b05ce68f3f3af6585b70d4129a5530269
    BUG: 1215026
    Signed-off-by: Sakshi <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13984
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 9 Kaushal 2016-04-19 07:12:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.