Bug 1215060 - soffice.bin killed by SIGFPE while Libreoffice tries to open the document which is exported from Polarion on f21
Summary: soffice.bin killed by SIGFPE while Libreoffice tries to open the document whi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-24 08:17 UTC by Rahul Hinduja
Modified: 2015-04-29 13:04 UTC (History)
6 users (show)

Fixed In Version: libreoffice-4.3.7.2-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 13:04:54 UTC


Attachments (Terms of Use)
core_backtrace (30.08 KB, text/plain)
2015-04-24 08:19 UTC, Rahul Hinduja
no flags Details

Description Rahul Hinduja 2015-04-24 08:17:47 UTC
Description of problem:
======================

I got the exported document from polarion in form of docx. But once tried to open it with libreoffice, LO detected an error (soffice.bin killed by SIGFPE) and failed to open.

LO Version: 4.3.6.2
LO Build ID: 4.3.6.2-8.fc21

Tried to open the same docx with the LO builds 4.2.8.2-7.fc20 and 4.1.6.2-7.fc19. It works fine.

Problem Details are as follows:
===============================

reason: soffice.bin killed by SIGFPE
executable: /usr/lib64/libreoffice/program/soffice.bin
kernel: 3.19.3-200.fc21.x86_64

core_backtrace will be attached


Version-Release number of selected component (if applicable):
=============================================================
4.3.6.2-8.fc21

How reproducible:
=================
Always


Steps to Reproduce:
===================
1. Export document from polarion in docx (I will be attaching the exported document for reference)
2. Open with libreoffice

Actual results:
==============

Does not open and errors with message "libreoffice quit unexpectedly" with reason "soffice.bin killed by SIGFPE"

Comment 1 Rahul Hinduja 2015-04-24 08:19:28 UTC
Created attachment 1018332 [details]
core_backtrace

Comment 3 Caolan McNamara 2015-04-24 15:10:01 UTC
fails in 4.3.6.2 works on todays upstream master

Comment 4 Caolan McNamara 2015-04-24 16:21:34 UTC
oh huh, seems I fixed the crash as part of the coverity drive, backporting those fixes and it loads for me with 4.3

Comment 5 Fedora Update System 2015-04-27 08:56:44 UTC
libreoffice-4.3.7.2-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libreoffice-4.3.7.2-3.fc21

Comment 6 Fedora Update System 2015-04-28 13:05:15 UTC
Package libreoffice-4.3.7.2-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.3.7.2-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7022/libreoffice-4.3.7.2-3.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-04-29 13:04:54 UTC
libreoffice-4.3.7.2-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.