Bug 1215091 - migration: 7.2->earlier; floppy compatibility
Summary: migration: 7.2->earlier; floppy compatibility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1174920
TreeView+ depends on / blocked
 
Reported: 2015-04-24 09:32 UTC by Dr. David Alan Gilbert
Modified: 2015-12-04 16:40 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:40:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Dr. David Alan Gilbert 2015-04-24 09:32:41 UTC
Description of problem:
Amit's checker spotted a difference in the fdc
See bug 1174920

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Miroslav Rezanina 2015-07-02 19:32:08 UTC
Fix included in qemu-kvm-rhev-2.3.0-7.el7

Comment 8 huiqingding 2015-08-07 05:14:00 UTC
Reproduce this bug using the following version:
RHEL7.2 host:
kernel-3.10.0-302.el7.x86_64
qemu-kvm-rhev-2.3.0-6.el7.x86_64

RHEL7.1 host:
kernel-3.10.0-229.12.1.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.8.x86_64

Steps to Reproduce:
1. boot a guest with a floppy (no image) in src RHEL7.2 host and RHEL7.1 host:
/usr/libexec/qemu-kvm -cpu Penryn -name test3 -S -machine pc-i440fx-rhel7.0.0,accel=kvm,usb=off -m 1000 -realtime mlock=off -smp 2,maxcpus=4,sockets=4,cores=1,threads=1 -uuid 7347d748-f7ce-448f-8d49-3d29c9bcac30 -no-user-config -nodefaults  -rtc base=utc -no-shutdown -boot strict=on  -drive file=/mnt/rhel7_1_qcow2,if=none,id=drive-ide0-0-0,format=qcow2 -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1  -spice port=5901,addr=0.0.0.0,disable-ticketing,seamless-migration=on -k en-us -device qxl-vga,id=video0,ram_size=134217728,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 -msg timestamp=on -monitor stdio -device intel-hda,id=sound3,bus=pci.0,addr=0x6 -device hda-duplex,id=sound3-codec0,bus=sound3.0,cad=0 -net none  -drive file=,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -boot menu=on -serial unix:/tmp/tty0,server,nowait

2. Type "Ctrl+c" into grub command

3. Hit the tab key a few times after the fd0 (don't hit return)
grub > boot (fd0)

4. Do migration
(qemu) migrate -d tcp:10.66.8.244:5800

5. Carry on hitting the tab during migration

Actual results:
after step4 and step5, migration is failed and qemu-kvm in dst host quits with:
(qemu) qemu: warning: error while loading state for instance 0x0 of device 'fdc'
2015-08-07T03:56:04.069912Z qemu-kvm: load of migration failed: No such file or directory

Comment 9 huiqingding 2015-08-07 07:50:15 UTC
Test this bug using the following version:
RHEL7.2 host:
kernel-3.10.0-302.el7.x86_64
qemu-kvm-rhev-2.3.0-15.el7.x86_64

RHEL7.1 host:
kernel-3.10.0-229.12.1.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.8.x86_64

RHEL7.0 host:
kernel-3.10.0-123.17.1.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.11.x86_64

Use the same steps of comment #8 to test, the results is as following:
Hosts           Machine Type         Results
----------------------------------------------
7.2->7.1        -M rhel7.1.0         pass
7.2->7.1        -M rhel7.0.0         pass
7.2->7.1        -M rhel6.6.0         pass
7.2->7.1        -M rhel6.5.0         pass
7.2->7.0        -M rhel7.0.0         pass
7.2->7.0        -M rhel6.5.0         pass

Comment 10 juzhang 2015-08-10 05:39:10 UTC
According to comment8 and comment9, set this issue as verified.

Comment 12 errata-xmlrpc 2015-12-04 16:40:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.