Bug 1215092 - migration: 7.2->earlier: pckbd compatibility
Summary: migration: 7.2->earlier: pckbd compatibility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1174920
TreeView+ depends on / blocked
 
Reported: 2015-04-24 09:35 UTC by Dr. David Alan Gilbert
Modified: 2015-12-04 16:40 UTC (History)
7 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:40:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Dr. David Alan Gilbert 2015-04-24 09:35:08 UTC
Description of problem:
Amit's checker spotted a difference in pckbd:
Paolo says 'pckbd was tuned to never generate the subsection in practice.  But we can disable the subsection altogether just to err on the side of safety.'
see bz 1174920

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Miroslav Rezanina 2015-07-02 19:32:15 UTC
Fix included in qemu-kvm-rhev-2.3.0-7.el7

Comment 5 huiqingding 2015-07-22 07:25:25 UTC
Reproduce this bug using the following version:
Src RHEL7.2 host:
kernel-3.10.0-297.el7.x86_64
qemu-kvm-rhev-2.3.0-5.el7.x86_64

Dst RHEL7.1 host:
kernel-3.10.0-229.10.1.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.6.x86_64

Steps to Reproduce:
1. boot a guest on src and host dst host:
# /usr/libexec/qemu-kvm -cpu Penryn -name test3 -S -machine pc-i440fx-rhel7.1.0,accel=kvm,usb=off -m 1000 -realtime mlock=off -smp 2,maxcpus=4,sockets=4,cores=1,threads=1 -uuid 7347d748-f7ce-448f-8d49-3d29c9bcac30 -no-user-config -nodefaults  -rtc base=utc -no-shutdown -boot strict=on  -drive file=/mnt/rhel7.1.qcow2,if=none,id=drive-ide0-0-0,format=qcow2 -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1  -spice port=5901,addr=0.0.0.0,disable-ticketing,seamless-migration=on -k en-us -device qxl-vga,id=video0,ram_size=134217728,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 -msg timestamp=on -monitor stdio -device intel-hda,id=sound3,bus=pci.0,addr=0x6 -device hda-duplex,id=sound3-codec0,bus=sound3.0,cad=0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=52:54:00:c6:4b:15,id=test,addr=0xa  -drive file=,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -boot menu=on -serial unix:/tmp/tty0,server,nowait

2. Login the guest through serial console. Inside guest, run the app of comment #2
# ./file

3. Do migration from RHEL7.2 host to RHEL7.1 host
(qemu) migrate -d tcp:10.66.85.215:5800

Actual results:
after step3, migration failed with:
(qemu) qemu: warning: error while loading state for instance 0x0 of device 'pckbd'
2015-07-22T07:19:58.007926Z qemu-kvm: load of migration failed: No such file or directory

Comment 6 huiqingding 2015-07-22 08:34:20 UTC
Test this bug using the following version:
Src RHEL7.2 host:
kernel-3.10.0-297.el7.x86_64
qemu-kvm-rhev-2.3.0-12.el7.x86_64

Dst RHEL7.1 host:
kernel-3.10.0-229.10.1.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.6.x86_64

Dst RHEL7.0 host:
kernel-3.10.0-123.17.1.el7.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.11.x86_64

Use the same command line and steps to do test as comment #5

Migration          Machine Type       Result
---------------------------------------------
rhel7.2-> rhel7.1  -M 7.1.0           pass
rhel7.2-> rhel7.1  -M 7.0.0           pass
rhel7.2-> rhel7.1  -M 6.6.0           pass
rhel7.2-> rhel7.1  -M 6.5.0           pass
rhel7.2-> rhel7.0  -M 7.0.0           pass
rhel7.2-> rhel7.0  -M 6.5.0           pass

Comment 7 juzhang 2015-07-27 04:41:16 UTC
According to comment5 and comment6, set this issue as verified.

Comment 9 errata-xmlrpc 2015-12-04 16:40:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.