Bug 1215117 - Disperse volume: rebalance and quotad crashed
Summary: Disperse volume: rebalance and quotad crashed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1215173 1215556 1224192 1245569
TreeView+ depends on / blocked
 
Reported: 2015-04-24 10:58 UTC by Bhaskarakiran
Modified: 2016-11-23 23:13 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1215173 1224192 1245569 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:54:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Bhaskarakiran 2015-04-24 10:58:10 UTC
Description of problem:
======================

Converted plain 1x*8+4) disperse volume to distributed disperse volume 2x(8+4). While there is IO running from the clients, started rebalance and seen two crashes

Version-Release number of selected component (if applicable):
=============================================================
[root@vertigo /]# gluster --version
glusterfs 3.7dev built on Apr 18 2015 01:08:09
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.

How reproducible:
=================
Tried only once 

Steps to Reproduce:
===================

As in description

Actual results:


Expected results:


Additional info:
================
Corefiles will be attached

Comment 2 Anand Avati 2015-04-24 13:30:45 UTC
REVIEW: http://review.gluster.org/10367 (timer: Fix use after free issue) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2015-04-25 05:19:14 UTC
COMMIT: http://review.gluster.org/10367 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 48de998d589350dafeb00bc6ecd22faa9f66b9da
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Apr 24 16:24:52 2015 +0530

    timer: Fix use after free issue
    
    Change-Id: I056c9777b242a11af7f576ad19b2db93dbdf82d4
    BUG: 1215117
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/10367
    Reviewed-by: Poornima G <pgurusid@redhat.com>
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Nithya Balachandran 2015-05-12 05:25:43 UTC
*** Bug 1214994 has been marked as a duplicate of this bug. ***

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 15:10:03 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 6 Niels de Vos 2016-06-16 12:54:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.