Bug 1215154 - [PATCH] dnf debuginfo-install: AttributeError: 'NoneType' object has no attribute 'replace'
[PATCH] dnf debuginfo-install: AttributeError: 'NoneType' object has no attri...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1221860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-24 08:33 EDT by Lubomir Rintel
Modified: 2015-05-15 13:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-08 03:27:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2015-04-24 08:33:21 EDT
Description of problem:

d[root@belphegor lkundrak]# dnf debuginfo-install network-manager-applet
Repository u'rhel' is missing name in configuration, using id.
Failed to synchronize cache for repo 'rpmfusion-free-debuginfo' from 'http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-debug-22&arch=x86_64': Cannot prepare internal mirrorlist: No URLs in mirrorlist, disabling.
Failed to synchronize cache for repo 'rpmfusion-free' from 'http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-22&arch=x86_64': Cannot prepare internal mirrorlist: No URLs in mirrorlist, disabling.
Fedora 22 - x86_64 - Updates - Debug                                                                                                                                               3.3 kB/s | 257  B     00:00    
Fedora 22 - x86_64 - Debug                                                                                                                                                          19 MB/s |  11 MB     00:00    
^[[1;5HFedora 22 - x86_64 - Test Updates Debug                                                 0% [                                                                                     ] ---  B/s |   0  B     --:Fedora 22 - x86_64 - Test Updates Debug                                                                                                                                             19 MB/s | 4.1 MB     00:00    
RPM Fusion for Fedora 22 - Free - Updates Debug                                                                                                                                    6.7 kB/s | 411  B     00:00    
Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1071, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/debuginfo-install.py", line 70, in run
    self._di_install(pkg)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/debuginfo-install.py", line 102, in _di_install
    srcname = self._pkgname_src(package)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/debuginfo-install.py", line 75, in _pkgname_src 
    name = package.sourcerpm.replace("-{}.src.rpm".format(package.evr), "")
AttributeError: 'NoneType' object has no attribute 'replace'
[root@belphegor lkundrak]# 



Version-Release number of selected component (if applicable):

 rpm -qa |grep dnf
dnf-0.6.5-1.fc22.noarch
python-dnf-plugins-extras-migrate-0.0.7-1.fc22.noarch
dnf-plugins-core-0.1.6-3.fc22.noarch
python-dnf-plugins-extras-common-0.0.7-1.fc22.noarch
python-dnf-0.6.5-1.fc22.noarch
python-dnf-plugins-core-0.1.6-3.fc22.noarch
dnf-conf-0.6.5-1.fc22.noarch
dnf-yum-0.6.5-1.fc22.noarch
Comment 1 Lubomir Rintel 2015-04-24 08:55:06 EDT
Seems like I can fix it:

https://github.com/rpm-software-management/dnf-plugins-core/pull/87
Comment 2 Honza Silhan 2015-04-24 10:55:50 EDT
PR was accepted and you were added to dnf-plugins-core authors, thanks
Comment 3 Fedora Update System 2015-05-02 09:49:55 EDT
dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
Comment 4 Fedora Update System 2015-05-03 13:24:49 EDT
Package dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.7-1.fc22 hawkey-0.5.5-1.fc22 dnf-1.0.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7483/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-05-08 03:27:31 EDT
dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Honza Silhan 2015-05-15 13:18:34 EDT
*** Bug 1221860 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.