Bug 1215156 - LVM RAID: device repair failure when losing all but one leg
Summary: LVM RAID: device repair failure when losing all but one leg
Keywords:
Status: CLOSED DUPLICATE of bug 1130329
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Heinz Mauelshagen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1138452
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-24 12:42 UTC by Jonathan Earl Brassow
Modified: 2016-03-10 12:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1138452
Environment:
Last Closed: 2016-03-10 12:20:45 UTC


Attachments (Terms of Use)

Comment 1 Jonathan Earl Brassow 2015-04-24 12:46:34 UTC
The last portion of the bug that has been cloned here is a separate bug related to RAID.  This should be investigated.

Relevant comments below:
##################################################
--- Additional comment from Corey Marthaler on 2014-09-09 15:44:46 EDT ---

This appears to be easier to hit when running in exclusive activation mode while in a cluster.

--- Additional comment from Corey Marthaler on 2014-09-09 15:45:50 EDT ---

Sep  9 14:23:18 host-114 qarshd[9101]: Running cmdline: pvs -a
Sep  9 14:23:18 host-114 kernel: md/raid1:mdX: active with 2 out of 4 mirrors
Sep  9 14:23:18 host-114 kernel: created bitmap (1 pages) for device mdX
Sep  9 14:23:18 host-114 kernel: md: mdX: recovery interrupted.
Sep  9 14:23:20 host-114 lvm[7548]: device-mapper: waitevent ioctl on  failed: Interrupted system call
Sep  9 14:25:18 host-114 lvm[7548]: Error locking on node host-114: Command timed out
Sep  9 14:25:18 host-114 xinetd[1932]: EXIT: qarsh status=0 pid=9101 duration=120(sec)
Sep  9 14:26:17 host-114 kernel: INFO: task clvmd:6558 blocked for more than 120 seconds.
Sep  9 14:26:17 host-114 kernel:      Not tainted 2.6.32-500.el6.x86_64 #1
Sep  9 14:26:17 host-114 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Sep  9 14:26:17 host-114 kernel: clvmd         D 0000000000000000     0  6558      1 0x00000080
Sep  9 14:26:17 host-114 kernel: ffff88003dcdfa18 0000000000000082 ffff88003dcdf9a8 ffffffff81041e98
Sep  9 14:26:17 host-114 kernel: ffff880000000000 0003ac9bb260140c ffff88003dcdf9e8 ffff88003cf70590
Sep  9 14:26:17 host-114 kernel: 00000000000a4588 ffffffffabf0b056 ffff88003d35bab8 ffff88003dcdffd8
Sep  9 14:26:17 host-114 kernel: Call Trace:
Sep  9 14:26:17 host-114 kernel: [<ffffffff81041e98>] ? pvclock_clocksource_read+0x58/0xd0
Sep  9 14:26:17 host-114 kernel: [<ffffffff810aaa21>] ? ktime_get_ts+0xb1/0xf0
Sep  9 14:26:17 host-114 kernel: [<ffffffff8152a1f3>] io_schedule+0x73/0xc0
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ce71d>] __blockdev_direct_IO_newtrunc+0xb7d/0x1270
Sep  9 14:26:17 host-114 kernel: [<ffffffff812965e0>] ? vsnprintf+0x450/0x5e0
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ca080>] ? blkdev_get_block+0x0/0x20
Sep  9 14:26:17 host-114 kernel: [<ffffffff8127a04d>] ? get_disk+0x7d/0xf0
Sep  9 14:26:17 host-114 kernel: [<ffffffff811cee87>] __blockdev_direct_IO+0x77/0xe0
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ca080>] ? blkdev_get_block+0x0/0x20
Sep  9 14:26:17 host-114 kernel: [<ffffffff811cb107>] blkdev_direct_IO+0x57/0x60
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ca080>] ? blkdev_get_block+0x0/0x20
Sep  9 14:26:17 host-114 kernel: [<ffffffff811261db>] generic_file_aio_read+0x6bb/0x700
Sep  9 14:26:17 host-114 kernel: [<ffffffff81234b51>] ? avc_has_perm+0x71/0x90
Sep  9 14:26:17 host-114 kernel: [<ffffffff81236a02>] ? selinux_inode_permission+0x72/0xb0
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ca4c1>] blkdev_aio_read+0x51/0x80
Sep  9 14:26:17 host-114 kernel: [<ffffffff8118de2a>] do_sync_read+0xfa/0x140
Sep  9 14:26:17 host-114 kernel: [<ffffffff8109eb00>] ? autoremove_wake_function+0x0/0x40
Sep  9 14:26:17 host-114 kernel: [<ffffffff811ca41c>] ? block_ioctl+0x3c/0x40
Sep  9 14:26:17 host-114 kernel: [<ffffffff811a36b2>] ? vfs_ioctl+0x22/0xa0
Sep  9 14:26:17 host-114 kernel: [<ffffffff8123a55b>] ? selinux_file_permission+0xfb/0x150
Sep  9 14:26:17 host-114 kernel: [<ffffffff8122d3b6>] ? security_file_permission+0x16/0x20
Sep  9 14:26:17 host-114 kernel: [<ffffffff8118e7e5>] vfs_read+0xb5/0x1a0
Sep  9 14:26:17 host-114 kernel: [<ffffffff8118e921>] sys_read+0x51/0x90
Sep  9 14:26:17 host-114 kernel: [<ffffffff810e5aee>] ? __audit_syscall_exit+0x25e/0x290
Sep  9 14:26:17 host-114 kernel: [<ffffffff8100b072>] system_call_fastpath+0x16/0x1b

Comment 6 Heinz Mauelshagen 2016-03-10 12:20:45 UTC

*** This bug has been marked as a duplicate of bug 1130329 ***


Note You need to log in before you can comment on or make changes to this bug.