Bug 1215197 - ipa-client-install ignores --ntp-server option during time sync
Summary: ipa-client-install ignores --ntp-server option during time sync
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-24 14:34 UTC by Petr Vobornik
Modified: 2015-11-19 12:03 UTC (History)
3 users (show)

Fixed In Version: ipa-4.2.0-0.1.alpha1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 12:03:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verify log for bz (871 bytes, text/plain)
2015-09-29 08:23 UTC, Pavel Picka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2362 0 normal SHIPPED_LIVE ipa bug fix and enhancement update 2015-11-19 10:40:46 UTC

Description Petr Vobornik 2015-04-24 14:34:26 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/4983

ipa-client-install try to sync time in following way:
* try to detect NTP server from SRV record
* in case of failure, use the IP address of IPA server as ntp server

the option --ntp-server is ignored, but a value of the option is used in ntp.conf.

Expected behavior:

server specified by --ntp-server  is used during time sync.

Comment 1 Petr Vobornik 2015-04-24 14:42:42 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/2c8c4b8c885fe34cc722cce91639230a7734c3f3

Comment 3 Pavel Picka 2015-09-29 08:23:13 UTC
Created attachment 1078217 [details]
Verify log for bz

Verified

ipa-client-4.2.0-12.el7.x86_64

more than one --ntp-server can be used

Comment 4 errata-xmlrpc 2015-11-19 12:03:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html


Note You need to log in before you can comment on or make changes to this bug.