Bug 1215294 - Emacs binding is on by default, Ctrl+k shortcut doesn't work
Summary: Emacs binding is on by default, Ctrl+k shortcut doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 1224605
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-25 01:08 UTC by Bastiaan Jacques
Modified: 2015-06-13 00:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-13 00:44:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Bastiaan Jacques 2015-04-25 01:08:39 UTC
Description of problem:

The Ctrl-k shortcut normally brings the quick-search bar into focus (by selecting its text). This generally works, but not when the address bar is currently in focus.

Version-Release number of selected component (if applicable):

firefox-37.0.2-2.fc22.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Click on the address bar.
2. Press Ctrl-k. Observe the that the address bar stays selected.
3. Click anywhere else in Firefox (say, somewhere on a web page) and press Ctrl-k. Observe that the focus is moved to the quick search bar.

Additional info:

Fedora 21 is not affected. I also downloaded an official (non-RPM) build of Firefox 37.0.2 and tested that it is not affected either. So I believe this is a not an upstream bug.

Comment 2 Carl-Johan Schenström 2015-04-27 10:58:49 UTC
Related bug/change in Gnome?

<https://bugzilla.gnome.org/show_bug.cgi?id=737346>

Comment 3 Victor A. Safronov 2015-05-29 10:52:54 UTC
Confirm. 
Something changed in F22 global hotkeys, and now Ctrl+K is used as an emacs binding - it deletes chars after the cursor till the end of line.
This binding now works in all apps, it is not related to Firefox itself, but FF has own useful binding for that hotkey, which now is inaccessible due to conflict with global settings.
Also, when googling for emacs-like bindings, there are a lot of old articles, that help to enable them, but not to disable.

See also: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Comment 4 Matthias Clasen 2015-06-13 00:44:18 UTC
The Emacs keybindings are _not_ on by default. Ctrl-k was added to GtkEntry shortcuts in response to an upstream feature request. According to https://en.wikipedia.org/wiki/Table_of_keyboard_shortcuts it is not emacs-specific at all, but traditional unix commandline editing.

In any case, I've just put instructions for how to turn it off into another bug.

*** This bug has been marked as a duplicate of bug 1224605 ***


Note You need to log in before you can comment on or make changes to this bug.