Bug 1215299 - Instack-undercloud: Error during instack-install-undercloud : ArgumentError: Could not parse rfc1738 URL from string '' .
Summary: Instack-undercloud: Error during instack-install-undercloud : ArgumentError: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-25 02:27 UTC by Omri Hochman
Modified: 2015-08-05 13:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Omri Hochman 2015-04-25 02:27:03 UTC
Instack-undercloud: Error during instack-install-undercloud : ArgumentError: Could not parse rfc1738 URL from string '' .


Environment:
-------------
instack-0.0.6.4-g57c723a.el7.centos.noarch
instack-undercloud-2.0.0-dev1665.el7.centos.noarch
openstack-tripleo-puppet-elements-0.0.0-post55.el7.centos.noarch
puppet-3.6.2-3.el7.noarch
openstack-heat-templates-4643876-0.99.20150327.1822git.el7.centos.noarch
openstack-tripleo-heat-templates-0.8.3-post37.el7.centos.noarch


Description: 
-------------

Not always reproducible - this error happened to me and to others, while following RDO-manager steps - when attempting to install RDO-manager on virt-environment - during the execution of the command 'instack-install-undercloud'. 

In my case I just re-provision the environment and tried to reproduce again, but couldn't reproduce.  although when it happened to other on different environment I've decided to report this Bz.      

Steps (not always reproduce) :
-------------------------------
1) follow the guide steps to deploy undercloud : https://repos.fedorapeople.org/repos/openstack-m/instack-undercloud/internal-html/install-undercloud.html


Results: the following error appear during the execution of the command 'instack-install-undercloud'. 


puppet view 
(during execution of 'instack-install-undercloud) : 
-----------
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns: CRITI [ironic] ArgumentError: Could not parse rfc1738 URL from string ''
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns: Traceback (most recent call last):
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/bin/ironic-dbsync", line 10, in <module>
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     sys.exit(main())
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/cmd/dbsync.py", line 110, in main
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     CONF.command.func()
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/cmd/dbsync.py", line 36, in upgrade
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     migration.upgrade(CONF.command.revision)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/migration.py", line 36, in upgrade
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     return get_backend().upgrade(version)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/migration.py", line 56, in upgrade
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     alembic.command.upgrade(config, revision or 'head')
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/alembic/command.py", line 165, in upgrade
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     script.run_env()
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/alembic/script.py", line 390, in run_env
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     util.load_python_file(self.dir, 'env.py')
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/alembic/util.py", line 243, in load_python_file
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     module = load_module_py(module_id, path)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/alembic/compat.py", line 79, in load_module_py
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     mod = imp.load_source(module_id, path, fp)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/alembic/env.py", line 54, in <module>
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     run_migrations_online()
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/alembic/env.py", line 46, in run_migrations_online
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     engine = sqla_api.get_engine()
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/api.py", line 59, in get_engine
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     facade = _create_facade_lazily()
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/ironic/db/sqlalchemy/api.py", line 54, in _create_facade_lazily
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     _FACADE = db_session.EngineFacade.from_config(CONF)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/session.py", line 902, in from_config
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     retry_interval=conf.database.retry_interval)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/session.py", line 818, in __init__
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     **engine_kwargs)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/session.py", line 377, in create_engine
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     url = sqlalchemy.engine.url.make_url(sql_connection)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/url.py", line 164, in make_url
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     return _parse_rfc1738_args(name_or_url)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/url.py", line 213, in _parse_rfc1738_args
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns:     "Could not parse rfc1738 URL from string '%s'" % name)
Notice: /Stage[main]/Ironic/Exec[ironic-dbsync]/returns: ArgumentError: Could not parse rfc1738 URL from string ''
Error: /Stage[main]/Ironic/Exec[ironic-dbsync]: Failed to call refresh: ironic-dbsync --config-file /etc/ironic/ironic.conf returned 1 instead of one of [0]
Error: /Stage[main]/Ironic/Exec[ironic-dbsync]: ironic-dbsync --config-file /etc/ironic/ironic.conf returned 1 instead of one of [0]

Comment 3 chris alfonso 2015-05-26 18:12:08 UTC
Omri, can you please retest this and if you are able to reproduce it, make the environment available for engineering to help debug the issue?

Comment 7 Omri Hochman 2015-06-22 16:15:03 UTC
Verified : 
-----------
instack-undercloud-2.1.2-1.el7ost.noarch
instack-0.0.7-1.el7ost.noarch

Comment 9 errata-xmlrpc 2015-08-05 13:51:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.