Bug 121531 - httpd doesn't require recent pcre version (and crashes with an old one)
Summary: httpd doesn't require recent pcre version (and crashes with an old one)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-22 14:34 UTC by Leszek Matok
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.0.49-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 20:07:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leszek Matok 2004-04-22 14:34:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
httpd-2.0.49-2 from Fedora/development segfaults when using pcre-3.4
(from some older RH system, worked fine with my previous
httpd-2.0.45-something). Upgrading to pcre-4.5 solved the problem
instantly, so all we have to do is require newer pcre.

Version-Release number of selected component (if applicable):
httpd-2.0.49-2

How reproducible:
Always

Steps to Reproduce:
1. Install httpd-2.0.49-2 and php-4.3.4-11 using pcre-3.4-* (I don't
remember the exact version, sorry)
2. Try to run phpBB2 or TWIG (it seems to be related to php or mysql,
however, other php+mysql sites didn't brake)
3. httpd process serving the request will crash
    

Additional info:

Comment 1 Joe Orton 2004-04-22 14:59:29 UTC
Thanks for the report.  I'll add a Conflicts: pcre < 4.0.


Note You need to log in before you can comment on or make changes to this bug.