Bug 121532 - "su -l" produces munged warning message on exit
Summary: "su -l" produces munged warning message on exit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-22 14:37 UTC by Tom London
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 00:39:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2004-04-22 14:37:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
From gnome-terminal, "su -l" on exit sometimes produces the following
type of messages in /var/log/messages:

Apr 21 20:00:48 fedora su(pam_unix)[7438]: session closed for user root
Apr 21 20:00:48 fedora su[7438]: Warning!  Could not relabel \2302^Q
with user_u:object_r:user_devpts_t, not relabeling.

(I have many of this type of message in the log. \230 is constant.
Next characters vary.....).  Rest of message constant.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-6

How reproducible:
Sometimes

Steps to Reproduce:
1. gnome-terminal, su -l
2. exit
3.
    

Additional info:

Comment 1 Tim Waugh 2004-04-22 15:42:06 UTC
This message comes from pam.

Comment 2 Tom London 2004-04-22 17:25:53 UTC
The bug occurs when you kill the window without exiting first from "su
-l".

So, here's how to reproduce it:
 1. as non-root user, within a gnome-terminal window, do "su -l" and
enter correct password.
 2. close the window without exiting from su shell.
 3. examine /var/log/messages.  You'll see warning message with
corrupted text.

Is this a NULL/dangling pointer?

Comment 3 Tomas Mraz 2004-09-13 12:07:16 UTC
Can't reproduce on pam-0.77-55.



Note You need to log in before you can comment on or make changes to this bug.