Bug 1215329 - repeatable freeze with nouveau
Summary: repeatable freeze with nouveau
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdrm
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-25 13:43 UTC by Matthew Miller
Modified: 2017-01-04 09:50 UTC (History)
7 users (show)

Fixed In Version: libdrm-2.4.61-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-10 23:38:33 UTC


Attachments (Terms of Use)
system log from crash (94.23 KB, text/plain)
2015-04-25 19:32 UTC, Matthew Miller
no flags Details
drm.debug=14 log of a reproduction which led to a temporary (15-30 second) freeze (1.12 MB, text/plain)
2015-04-27 18:37 UTC, Adam Williamson (Fedora)
no flags Details
trimmed log of first attempt to reproduce (without drm.debug=14) (87.26 KB, text/plain)
2015-04-27 18:39 UTC, Adam Williamson (Fedora)
no flags Details

Description Matthew Miller 2015-04-25 13:43:32 UTC
Description of problem:

This seems kind of weird, but I can reliably trigger a hang of the GUI on my system by running geeqie and right-clicking on the file list. The context menu comes up, but the mouse and keyboard immediately become nonresponsive. I can ssh in and reboot, though.


Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau-1.0.11-2.fc22.x86_64

How reproducible:

Seems to be always.

Steps to Reproduce:
1. run geeqie in a directory with a number of jpg files
2. right click on one of those files in the list
3. boom

Actual results:

mouse and keyboard freeze

Expected results:

not that.

Additional info:

system log is full of lines like:

Apr 24 21:26:22 system.example.org kernel: nouveau E[   PFIFO][0000:01:00.0] PBDMA0: ch 1 [DRM] subc 0 mthd 0x001c data 0x00001004
Apr 24 21:26:22 system.example.org systemd-journal[477]: Missed 16 kernel messages
Apr 24 21:26:22 system.example.org kernel: nouveau E[   PFIFO][0000:01:00.0] PBDMA0: ch 1 [DRM] subc 0 mthd 0x001c data 0x00001004
Apr 24 21:26:22 system.example.org systemd-journal[477]: Missed 16 kernel messages
Apr 24 21:26:22 system.example.org kernel: nouveau E[   PFIFO][0000:01:00.0] PBDMA0: ch 1 [DRM] subc 0 mthd 0x001c data 0x00001004
Apr 24 21:26:22 system.example.org systemd-journal[477]: Missed 19 kernel messages
Apr 24 21:26:22 system.example.org kernel: nouveau E[   PFIFO][0000:01:00.0] PBDMA0: ACQUIRE


And by "full", I mean about 7.6 million lines of that in a few minutes -- so much that it seems to have wiped out previous log information by sheer volume, triggering systemd's log rotation.

Comment 1 Matthew Miller 2015-04-25 13:47:10 UTC
This is a Thinkpad W530, and the boot log says Chipset: GK107 (NVE7)

Comment 2 Matthew Miller 2015-04-25 15:24:18 UTC
I should also add that this is a regression -- no problem in F21.

Comment 3 Matthew Miller 2015-04-25 19:32:04 UTC
Created attachment 1018842 [details]
system log from crash

Recreated again and got a possibly more helpful log, including some kind of numeric dump.

Comment 4 Matthew Miller 2015-04-26 17:39:18 UTC
Also of note: running under Gnome shell.

Comment 5 Adam Williamson (Fedora) 2015-04-27 18:36:24 UTC
I can reproduce this to at least some extent on my 9600 GT (10DE:0622). The first time I tried, on a regular boot, it happened right away, and stayed frozen for some time, and I rebooted remotely via ssh. Then I booted with 'drm.debug=14', and at first I couldn't reproduce it - but after several tries, I did hit a *temporary* freeze. After some seconds, though - 15-30 - the system started responding again.

I'll attach logs from both boots.

Comment 6 Adam Williamson (Fedora) 2015-04-27 18:37:05 UTC
Created attachment 1019408 [details]
drm.debug=14 log of a reproduction which led to a temporary (15-30 second) freeze

Comment 7 Adam Williamson (Fedora) 2015-04-27 18:39:25 UTC
Created attachment 1019409 [details]
trimmed log of first attempt to reproduce (without drm.debug=14)

Comment 8 Adam Williamson (Fedora) 2015-04-27 18:41:38 UTC
Note, it would probably be a good idea to report this to upstream (bugs.freedesktop.org), as more devs will see it there.

Comment 9 Matthew Miller 2015-04-27 19:09:49 UTC
Thanks Adam!

https://bugs.freedesktop.org/show_bug.cgi?id=90201

Comment 10 Matthew Miller 2015-04-28 12:08:52 UTC
This appears to be related to a regression in libdrm. See https://bugs.freedesktop.org/show_bug.cgi?id=89842

Comment 11 Adam Williamson 2015-05-06 22:17:05 UTC
http://cgit.freedesktop.org/mesa/drm/commit/?id=812e8fe6ce46d733c30207ee26c788c61f546294 is intended to fix this, I'll backport it to Rawhide and F22 (seems like a good idea to get this fixed).

Comment 12 Ben Skeggs 2015-05-06 22:53:36 UTC
(In reply to Adam Williamson from comment #11)
> http://cgit.freedesktop.org/mesa/drm/commit/
> ?id=812e8fe6ce46d733c30207ee26c788c61f546294 is intended to fix this, I'll
> backport it to Rawhide and F22 (seems like a good idea to get this fixed).
I plan on trying to get a libdrm 2.4.61 released today, and into Fedora.

Comment 13 Adam Williamson 2015-05-06 23:05:47 UTC
oh cool, in that case I'll skip the backport :) there's 6 days till F22 freeze so it should be fine (and we can propose a freeze exception if needed).

Comment 14 Adam Williamson 2015-05-07 00:28:08 UTC
I did test the backport as a scratch build and it seems to fix the problem, I couldn't reproduce it with the geeqie reproducer.

Comment 15 Fedora Update System 2015-05-07 03:40:21 UTC
libdrm-2.4.61-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libdrm-2.4.61-3.fc22

Comment 16 Fedora Update System 2015-05-10 23:38:33 UTC
libdrm-2.4.61-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Omar 2015-08-28 11:12:31 UTC
The problems still persist. I'm running in to this same problem with Fedora 22 even though I have updated libdrm to version libdrm-2.4.61-3.fc22.


Note You need to log in before you can comment on or make changes to this bug.