Bug 1215439 - python-urllib3-1.10.3-1.fc22 breaks python-bugzilla
Summary: python-urllib3-1.10.3-1.fc22 breaks python-bugzilla
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-urllib3
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1215981 1215982 1217524 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-26 15:11 UTC by Cole Robinson
Modified: 2015-05-01 18:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 18:40:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Cole Robinson 2015-04-26 15:11:15 UTC
$ bugzilla --debug query --bug_id 1044561
...
Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 1260, in <module>
    main()
  File "/usr/bin/bugzilla", line 1225, in main
    buglist = _do_query(bz, opt, parser)
  File "/usr/bin/bugzilla", line 720, in _do_query
    return bz.query(q)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 1212, in query
    r = self._query(query)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 1203, in _query
    return self._proxy.Bug.search(query)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1233, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 168, in _ServerProxy__request
    ret = ServerProxy._ServerProxy__request(self, methodname, params)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1591, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 263, in request
    return self._request_helper(url, request_body)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 250, in _request_helper
    raise e
BugzillaError: not well-formed (invalid token): line 1, column 0


Telling bugzilla to skip cached auth, or deleting ~/.bugzilla* doesn't make any difference. Downgrading python-urllib3 fixes things, regardless of whether it's with python-requests-2.6 or 2.5

Comment 1 Cole Robinson 2015-04-26 16:27:06 UTC
It's fixed in python-urllib3 git HEAD, fixed commit is:

commit 2cfc21644ae868e0ac8b5f24a27eabda8a1ebc1e
Author: Ian Cordasco <ian.cordasco@rackspace.com>
Date:   Thu Apr 23 08:57:53 2015 -0500

    Decode information received from read_chunked in stream
    
    Previously, when we read chunked data we always decoded it because it
    was handled by the read method on the HTTPResponse. Now that it's a
    separate method, we need to handle it. This is a quick fix for #593 to
    address a regression in behaviour.
    
    Fixes #593


Check git log for other references to 593 since there appears to be other commits for it as well, but maybe it's best to just grab .git

Comment 2 Ralph Bean 2015-04-27 13:56:48 UTC
I asked upstream to cut a new release:  https://github.com/shazow/urllib3/issues/600

They're usually quick about it once asked.  If it doesn't come soon, we can cut over to a git snapshot.

Comment 3 Cole Robinson 2015-04-28 13:27:07 UTC
*** Bug 1215981 has been marked as a duplicate of this bug. ***

Comment 4 Cole Robinson 2015-04-28 13:27:21 UTC
*** Bug 1215982 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-04-29 14:25:30 UTC
python-requests-2.6.2-1.fc22,python-urllib3-1.10.3-2.20150429git585983a.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-requests-2.6.2-1.fc22,python-urllib3-1.10.3-2.20150429git585983a.fc22

Comment 6 Cole Robinson 2015-04-30 15:58:23 UTC
*** Bug 1217524 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-05-01 16:43:39 UTC
python-urllib3-1.10.3-2.20150429git585983a.fc22, python-requests-2.6.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.