Bug 121546 - Program crash when user cancels a ppp modem connection
Program crash when user cancels a ppp modem connection
Status: CLOSED DUPLICATE of bug 109604
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-22 13:37 EDT by Rubén
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rubén 2004-04-22 13:37:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.4.1)
Gecko/20031030

Description of problem:
If you launch a modem connection and press cancel before can be made
then redhat-config-network exits with error and connection isn't
cancelled.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.Launch redhat-config-network
2.Start a modem connection
3.Press cancel button before connection finished
    

Actual Results:  Connection isn't stopped, and an error screen is
displayed.

Expected Results:  Connection stopped

Additional info:

This is the error exit that is displayed:
Component: redhat-config-network
Version: 1.3.10
Summary: TB3fbf821d GUI_functions.py:524:gui_run_dialog:OSError:
[Errno 1] Operaci�n no permitida
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 184, in
on_activateButton_clicked
    (ret, msg) = dev.activate()
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 385, in activate
    dialog = dialog)
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 512, in generic_run_dialog
    dialog = dialog)
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 524, in gui_run_dialog
OSError: [Errno 1] Operaci�n no permitida

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0xa42e56c>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0xa42e6b4>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0xa4617b4>
cancelbutton: <gtk.Button object (GtkButton) at 0xa454104>
command: /sbin/ifup
argv: ['/sbin/ifup', 'Terra24', 'up']
searchPath: 0
label: Activaci�n del dispositivo de red Terra24, espere...
lbl: <gtk.Label object (GtkLabel) at 0xa3b77ac>
select: <module 'select' from
'/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0xa453b84>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0xa3b7784>
errlabel: No puede activar el dispositivo de red Terra24!

fdout: []
root: /
gtk: <module 'gtk' from
'/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0xa4619dc>
write: 4
read: 3
s: 1
childpid: 4580
closefd: -1
dialog: None
rc: 
title: redhat-config-network:

Activaci�n del dispositivo de red...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0xa459a1c>
Comment 1 Harald Hoyer 2004-05-24 05:47:01 EDT

*** This bug has been marked as a duplicate of 109604 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.