Bug 1215565 - Python-requests-kerberos requires non-existent python-kerberos in version 1.1.1
Summary: Python-requests-kerberos requires non-existent python-kerberos in version 1.1.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-requests-kerberos
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Callaghan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-27 07:06 UTC by zdenek.pizl
Modified: 2015-06-26 16:10 UTC (History)
1 user (show)

Fixed In Version: python-requests-kerberos-0.7.0-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-23 09:09:54 UTC


Attachments (Terms of Use)

Description zdenek.pizl 2015-04-27 07:06:57 UTC
Description of problem:


Any script using python-requests-kerberos ends with an error like this one:

    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: kerberos==1.1.1


Version-Release number of selected component (if applicable):

- python-requests-kerberos-0.6-1.el6.noarch
- python-kerberos-1.1-7.el6.x86_64

How reproducible:

Run any python script importing/requesting python-requests-kerberos and python-kerberos installed from EPEL6 and EL6 repos. It will fail with message mentioned above.


Actual results:

cat /usr/lib/python2.6/site-packages/requests_kerberos-0.6-py2.6.egg-info/requires.txt
requests>=1.1.0
kerberos==1.1.1


Expected results:

cat /usr/lib/python2.6/site-packages/requests_kerberos-0.6-py2.6.egg-info/requires.txt
requests>=1.1.0
kerberos==1.1

Additional info:

Comment 1 zdenek.pizl 2015-04-30 07:46:29 UTC
--- requests_kerberos.egg-info/requires.txt.orig    2015-04-27 15:52:51.000000000 +0200
+++ requests_kerberos.egg-info/requires.txt    2015-04-22 14:40:45.000000000 +0200
@@ -1,2 +1,2 @@
 requests>=1.1.0
-kerberos==1.1.1
+kerberos==1.1

Comment 2 Dan Callaghan 2015-06-11 04:06:53 UTC
Just importing requests_kerberos doesn't reproduce this, but requiring it through pkg_resources does.

Python 2.6.6 (r266:84292, Nov 21 2013, 10:50:32) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import requests_kerberos
>>> __requires__ = ['requests-kerberos']
>>> import pkg_resources
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: kerberos==1.1.1
>>>

Comment 4 Fedora Update System 2015-06-11 06:51:04 UTC
python-requests-kerberos-0.7.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-requests-kerberos-0.7.0-2.fc22

Comment 5 Fedora Update System 2015-06-11 06:51:34 UTC
python-requests-kerberos-0.7.0-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-requests-kerberos-0.7.0-2.fc21

Comment 6 Fedora Update System 2015-06-11 06:58:17 UTC
python-requests-kerberos-0.7.0-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-requests-kerberos-0.7.0-2.el7

Comment 7 Fedora Update System 2015-06-11 06:58:45 UTC
python-requests-kerberos-0.7.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-requests-kerberos-0.7.0-2.el6

Comment 8 Fedora Update System 2015-06-11 18:45:30 UTC
Package python-requests-kerberos-0.7.0-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-requests-kerberos-0.7.0-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-6654/python-requests-kerberos-0.7.0-2.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-06-23 09:09:54 UTC
python-requests-kerberos-0.7.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-06-23 09:14:59 UTC
python-requests-kerberos-0.7.0-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-06-26 16:10:21 UTC
python-requests-kerberos-0.7.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-06-26 16:10:30 UTC
python-requests-kerberos-0.7.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.