Bug 121567 - Warning message when logged into Squirrelmail (register_globals)
Summary: Warning message when logged into Squirrelmail (register_globals)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: squirrelmail (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-23 08:14 UTC by Greg Williams
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 01:49:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Williams 2004-04-23 08:14:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
The following warning appears at the bottom of every page when logged in.

This is the default PHP settings and a couple of extra squirrelmail
modules loaded (spamassassin and others)

Warning: Unknown(): Your script possibly relies on a session
side-effect which existed until PHP 4.2.3. Please be advised that the
session extension does not consider global variables as a source of
data, unless register_globals is enabled. You can disable this
functionality and this warning by setting session.bug_compat_42 or
session.bug_compat_warn to off, respectively. in Unknown on line 0

Version-Release number of selected component (if applicable):
squirrelmail-1.2.11-1

How reproducible:
Always

Steps to Reproduce:
Enable certain extra modules in squirrelmail.  I am unsure which one
produces this message since the warning message refers to the file:
unknown rather than an actual filename.
    

Actual Results:  The warning message in the description appears at the
bottom of each page.

Expected Results:  The warning message shouldn't appear at all.

Additional info:

Turning register_globals to on is not an option.

Comment 1 Warren Togami 2004-10-21 01:49:25 UTC
This is fixed with newer squirrelmail in RHEL3 U1 and higher.



Note You need to log in before you can comment on or make changes to this bug.