Bug 121568 - scp remote remote with password authentication doesn't work
Summary: scp remote remote with password authentication doesn't work
Status: CLOSED DUPLICATE of bug 103364
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 27831
TreeView+ depends on / blocked
 
Reported: 2004-04-23 08:50 UTC by Ronny Buchmann
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for scp (348 bytes, patch)
2004-04-23 08:55 UTC, Ronny Buchmann
no flags Details | Diff
second attempt (858 bytes, patch)
2004-04-24 16:45 UTC, Ronny Buchmann
no flags Details | Diff

Description Ronny Buchmann 2004-04-23 08:50:38 UTC
Description of problem:

"scp userx@host1:file usery@host2:" doesn't prompt for password of
usery@host2 and fails


Version-Release number of selected component (if applicable):
3.6.1.p2-19

How reproducible:
always

Additiional Info:
A password is only read from /dev/tty, but when running scp (or ssh
with a 
command), you don't get a tty.

in sshconnect2.c:
userauth_passwd()
...
         password = read_passphrase(prompt, 0);


One can try:

ssh -t -x userx@host1 "ssh usery@host2"

wich actually works (as it forces tty allocation), without -t you get
the same 
error, as when doing remote to remote scp.

So to scp between remote hosts, you need to:

ssh -t -x userx@host1 "scp file usery@host2"

Comment 1 Ronny Buchmann 2004-04-23 08:55:52 UTC
Created attachment 99646 [details]
fix for scp

I think this fixes scp, but I did not test it yet.

Comment 2 Ronny Buchmann 2004-04-24 16:45:18 UTC
Created attachment 99677 [details]
second attempt

this one actually works, but I don't know if the removal of -n has any security
implications. I hope someone can comment on this.

Comment 3 Ronny Buchmann 2004-10-19 17:38:33 UTC

*** This bug has been marked as a duplicate of 103364 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:02:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.