Bug 1215706 - Major feature regression in gwenview
Summary: Major feature regression in gwenview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwenview
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-27 14:04 UTC by Martin Kyral
Modified: 2016-01-08 14:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-08 14:47:15 UTC
Type: Bug


Attachments (Terms of Use)
screenshot with some flaws marked (530.81 KB, image/png)
2015-04-27 14:04 UTC, Martin Kyral
no flags Details
misrotated image (293.46 KB, image/png)
2015-04-28 07:34 UTC, Martin Kyral
no flags Details

Description Martin Kyral 2015-04-27 14:04:59 UTC
Created attachment 1019335 [details]
screenshot with some flaws marked

Description of problem:
More than year ago, support for previewing RAW images has been introduced in gwenview. The feature depends on the kdcraw library.

In current updates, qt5 port of gwenview is going to land in Fedora. Nevertheless, KF5 port of kdcraw is not yet ready resulting in loss of the feature. Currently, almost all the RAW images are displayed incorrectly and due to API breakage introduced by https://bugreports.qt.io/browse/QTBUG-37946 many jpeg images are mis-rotated (the change is going to be reverted in QT 5.5).

Thus, qt4 version of gwenview need to be shipped until feature-full qt5 port is ready.


Version-Release number of selected component (if applicable):
gwenview-15.04.0-1.fc22

Steps to Reproduce:
1. View RAW images or jpegs rotated by the EXIF tag only (typically jpegs produced by the cameras)
2.
3.

Actual results:
RAW images are broken (only 160x120px thumbnail of error or wrong colours. CR2 /Canon) are displayed correctly though), some jpgs mis-rorated and mis-resized.


Expected results:
All kinds of images are displayed properly just as with gwenview 4.13+.


Additional info:

Comment 1 Rex Dieter 2015-04-27 17:44:18 UTC
I think I agree, without libkdcraw or libkipi support, kf5 gwenview is definitely a regression.

I'm in favor of reverting (at least until kf5-kdcraw and kf5-kipi are ready).

Anyone else?

Comment 2 Lukáš Tinkl 2015-04-27 18:54:16 UTC
Wouldn't it be better to actually patch Qt instead? See https://codereview.qt-project.org/#/c/110668/

Comment 3 Rex Dieter 2015-04-27 18:56:54 UTC
That's just one issue (though I personally prefer images to be auto-rotated)

Comment 4 Fedora Update System 2015-04-27 19:12:56 UTC
amor-15.04.0-1.fc22, analitza-15.04.0-1.fc22, ark-15.04.0-1.fc22, audiocd-kio-15.04.0-1.fc22, blinken-15.04.0-1.fc22, calligra-2.9.2-4.fc22, cantor-15.04.0-1.fc22, digikam-4.9.0-2.fc22, dragon-15.04.0-1.fc22, filelight-15.04.0-1.fc22, jovie-15.04.0-1.fc22, juk-15.04.0-1.fc22, kaccessible-15.04.0-1.fc22, kalgebra-15.04.0-1.fc22, kalzium-15.04.0-1.fc22, kamera-15.04.0-1.fc22, kanagram-15.04.0-1.fc22, kapptemplate-15.04.0-1.fc22, kate-15.04.0-1.fc22, kbruch-15.04.0-1.fc22, kcalc-15.04.0-1.fc22, kcharselect-15.04.0-1.fc22, kcolorchooser-15.04.0-1.fc22, kcron-15.04.0-1.fc22, kdeartwork-15.04.0-1.fc22, kdeedu-data-15.04.0-1.fc22, kdegraphics-mobipocket-15.04.0-1.fc22, kdegraphics-strigi-analyzer-15.04.0-1.fc22, kdegraphics-thumbnailers-15.04.0-1.fc22, kdenetwork-filesharing-15.04.0-1.fc22, kdenetwork-strigi-analyzers-15.04.0-1.fc22, kde-wallpapers-15.04.0-1.fc22, kdf-15.04.0-1.fc22, kdnssd-15.04.0-1.fc22, kfloppy-15.04.0-1.fc22, kgamma-15.04.0-1.fc22, kgeography-15.04.0-1.fc22, kget-15.04.0-1.fc22, kgpg-15.04.0-1.fc22, khangman-15.04.0-1.fc22, kig-15.04.0-1.fc22, kiten-15.04.0-1.fc22, klettres-15.04.0-1.fc22, kmag-15.04.0-1.fc22, kmix-15.04.0-1.fc22, kmousetool-15.04.0-1.fc22, kmouth-15.04.0-1.fc22, kmplot-15.04.0-1.fc22, kolourpaint-15.04.0-1.fc22, konsole5-15.04.0-1.fc22, kopete-15.04.0-1.fc22, kphotoalbum-4.6.1-2.fc22, kppp-15.04.0-1.fc22, kqtquickcharts-15.04.0-1.fc22, krdc-15.04.0-1.fc22, kremotecontrol-15.04.0-1.fc22, krfb-15.04.0-1.fc22, kruler-15.04.0-1.fc22, ksaneplugin-15.04.0-1.fc22, kscd-15.04.0-1.fc22, ksnapshot-15.04.0-1.fc22, kstars-15.04.0-1.fc22, ksystemlog-15.04.0-1.fc22, kteatime-15.04.0-1.fc22, ktimer-15.04.0-1.fc22, ktouch-15.04.0-1.fc22, kturtle-15.04.0-1.fc22, kuser-15.04.0-1.fc22, kwalletmanager-15.04.0-1.fc22, kwordquiz-15.04.0-1.fc22, libkcddb-15.04.0-1.fc22, libkcompactdisc-15.04.0-1.fc22, libkdcraw-15.04.0-1.fc22, libkdeedu-15.04.0-1.fc22, libkeduvocdocument-15.04.0-1.fc22, libkexiv2-15.04.0-1.fc22, libkface-15.04.0-1.fc22, libkgeomap-15.04.0-2.fc22, libkipi-15.04.0-1.fc22, libksane-15.04.0-1.fc22, marble-15.04.0-2.fc22, okular-15.04.0-1.fc22, pairs-15.04.0-1.fc22, parley-15.04.0-1.fc22, step-15.04.0-1.fc22, subsurface-4.4.1-4.fc22, superkaramba-15.04.0-1.fc22, svgpart-15.04.0-1.fc22, sweeper-15.04.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-6885/amor-15.04.0-1.fc22,analitza-15.04.0-1.fc22,ark-15.04.0-1.fc22,audiocd-kio-15.04.0-1.fc22,blinken-15.04.0-1.fc22,calligra-2.9.2-4.fc22,cantor-15.04.0-1.fc22,digikam-4.9.0-2.fc22,dragon-15.04.0-1.fc22,filelight-15.04.0-1.fc22,jovie-15.04.0-1.fc22,juk-15.04.0-1.fc22,kaccessible-15.04.0-1.fc22,kalgebra-15.04.0-1.fc22,kalzium-15.04.0-1.fc22,kamera-15.04.0-1.fc22,kanagram-15.04.0-1.fc22,kapptemplate-15.04.0-1.fc22,kate-15.04.0-1.fc22,kbruch-15.04.0-1.fc22,kcalc-15.04.0-1.fc22,kcharselect-15.04.0-1.fc22,kcolorchooser-15.04.0-1.fc22,kcron-15.04.0-1.fc22,kdeartwork-15.04.0-1.fc22,kdeedu-data-15.04.0-1.fc22,kdegraphics-mobipocket-15.04.0-1.fc22,kdegraphics-strigi-analyzer-15.04.0-1.fc22,kdegraphics-thumbnailers-15.04.0-1.fc22,kdenetwork-filesharing-15.04.0-1.fc22,kdenetwork-strigi-analyzers-15.04.0-1.fc22,kde-wallpapers-15.04.0-1.fc22,kdf-15.04.0-1.fc22,kdnssd-15.04.0-1.fc22,kfloppy-15.04.0-1.fc22,kgamma-15.04.0-1.fc22,kgeography-15.04.0-1.fc22,kget-15.04.0-1.fc22,kgpg-15.04.0-1.fc22,khangman-15.04.0-1.fc22,kig-15.04.0-1.fc22,kiten-15.04.0-1.fc22,klettres-15.04.0-1.fc22,kmag-15.04.0-1.fc22,kmix-15.04.0-1.fc22,kmousetool-15.04.0-1.fc22,kmouth-15.04.0-1.fc22,kmplot-15.04.0-1.fc22,kolourpaint-15.04.0-1.fc22,konsole5-15.04.0-1.fc22,kopete-15.04.0-1.fc22,kphotoalbum-4.6.1-2.fc22,kppp-15.04.0-1.fc22,kqtquickcharts-15.04.0-1.fc22,krdc-15.04.0-1.fc22,kremotecontrol-15.04.0-1.fc22,krfb-15.04.0-1.fc22,kruler-15.04.0-1.fc22,ksaneplugin-15.04.0-1.fc22,kscd-15.04.0-1.fc22,ksnapshot-15.04.0-1.fc22,kstars-15.04.0-1.fc22,ksystemlog-15.04.0-1.fc22,kteatime-15.04.0-1.fc22,ktimer-15.04.0-1.fc22,ktouch-15.04.0-1.fc22,kturtle-15.04.0-1.fc22,kuser-15.04.0-1.fc22,kwalletmanager-15.04.0-1.fc22,kwordquiz-15.04.0-1.fc22,libkcddb-15.04.0-1.fc22,libkcompactdisc-15.04.0-1.fc22,libkdcraw-15.04.0-1.fc22,libkdeedu-15.04.0-1.fc22,libkeduvocdocument-15.04.0-1.fc22,libkexiv2-15.04.0-1.fc22,libkface-15.04.0-1.fc22,libkgeomap-15.04.0-2.fc22,libkipi-15.04.0-1.fc22,libksane-15.04.0-1.fc22,marble-15.04.0-2.fc22,okular-15.04.0-1.fc22,pairs-15.04.0-1.fc22,parley-15.04.0-1.fc22,step-15.04.0-1.fc22,subsurface-4.4.1-4.fc22,superkaramba-15.04.0-1.fc22,svgpart-15.04.0-1.fc22,sweeper-15.04.0-1.fc22

Comment 5 Rex Dieter 2015-04-27 19:13:57 UTC
the kde-apps-15.04.0 update no longer includes gwenview-15.04.0, we'll try to deal with that in a separate update.

Comment 6 Martin Kyral 2015-04-28 07:34:41 UTC
Created attachment 1019554 [details]
misrotated image

(In reply to Rex Dieter from comment #3)
> That's just one issue (though I personally prefer images to be auto-rotated)

Please note, that gwenview actually auto-rotates images and it works quite well. Unfortunatelly with the QImage change, the images (only those being rotated by the exif tag) are being rotated once again when displaying, even after the viewing area is prepared, so the result looks really weird.

Comment 7 Martin Kyral 2015-04-30 06:59:42 UTC
QT dropped the problematic auto-rotating patch in 5.4.2: https://codereview.qt-project.org/#/c/111398/

Thus, the only problem now is the missing libkdcraw and libkipi in KF5.

Comment 8 Fedora Update System 2015-05-01 16:45:44 UTC
amor-15.04.0-1.fc22, analitza-15.04.0-1.fc22, ark-15.04.0-1.fc22, audiocd-kio-15.04.0-1.fc22, blinken-15.04.0-1.fc22, calligra-2.9.2-4.fc22, cantor-15.04.0-1.fc22, digikam-4.9.0-2.fc22, dragon-15.04.0-1.fc22, filelight-15.04.0-1.fc22, jovie-15.04.0-1.fc22, juk-15.04.0-1.fc22, kaccessible-15.04.0-1.fc22, kalgebra-15.04.0-1.fc22, kalzium-15.04.0-1.fc22, kamera-15.04.0-1.fc22, kanagram-15.04.0-1.fc22, kapptemplate-15.04.0-1.fc22, kate-15.04.0-1.fc22, kbruch-15.04.0-1.fc22, kcalc-15.04.0-1.fc22, kcharselect-15.04.0-1.fc22, kcolorchooser-15.04.0-1.fc22, kcron-15.04.0-1.fc22, kdeartwork-15.04.0-1.fc22, kdeedu-data-15.04.0-1.fc22, kdegraphics-mobipocket-15.04.0-1.fc22, kdegraphics-strigi-analyzer-15.04.0-1.fc22, kdegraphics-thumbnailers-15.04.0-1.fc22, kdenetwork-filesharing-15.04.0-1.fc22, kdenetwork-strigi-analyzers-15.04.0-1.fc22, kde-wallpapers-15.04.0-1.fc22, kdf-15.04.0-1.fc22, kdnssd-15.04.0-1.fc22, kfloppy-15.04.0-1.fc22, kgamma-15.04.0-1.fc22, kgeography-15.04.0-1.fc22, kget-15.04.0-1.fc22, kgpg-15.04.0-1.fc22, khangman-15.04.0-1.fc22, kig-15.04.0-1.fc22, kiten-15.04.0-1.fc22, klettres-15.04.0-1.fc22, kmag-15.04.0-1.fc22, kmix-15.04.0-1.fc22, kmousetool-15.04.0-1.fc22, kmouth-15.04.0-1.fc22, kmplot-15.04.0-1.fc22, kolourpaint-15.04.0-1.fc22, konsole5-15.04.0-1.fc22, kopete-15.04.0-1.fc22, kphotoalbum-4.6.1-2.fc22, kppp-15.04.0-1.fc22, kqtquickcharts-15.04.0-1.fc22, krdc-15.04.0-1.fc22, kremotecontrol-15.04.0-1.fc22, krfb-15.04.0-1.fc22, kruler-15.04.0-1.fc22, ksaneplugin-15.04.0-1.fc22, kscd-15.04.0-1.fc22, ksnapshot-15.04.0-1.fc22, kstars-15.04.0-1.fc22, ksystemlog-15.04.0-1.fc22, kteatime-15.04.0-1.fc22, ktimer-15.04.0-1.fc22, ktouch-15.04.0-1.fc22, kturtle-15.04.0-1.fc22, kuser-15.04.0-1.fc22, kwalletmanager-15.04.0-1.fc22, kwordquiz-15.04.0-1.fc22, libkcddb-15.04.0-1.fc22, libkcompactdisc-15.04.0-1.fc22, libkdcraw-15.04.0-1.fc22, libkdeedu-15.04.0-1.fc22, libkeduvocdocument-15.04.0-1.fc22, libkexiv2-15.04.0-1.fc22, libkface-15.04.0-1.fc22, libkgeomap-15.04.0-2.fc22, libkipi-15.04.0-1.fc22, libksane-15.04.0-1.fc22, marble-15.04.0-2.fc22, okular-15.04.0-1.fc22, pairs-15.04.0-1.fc22, parley-15.04.0-1.fc22, step-15.04.0-1.fc22, subsurface-4.4.1-4.fc22, superkaramba-15.04.0-1.fc22, svgpart-15.04.0-1.fc22, sweeper-15.04.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Martin Kyral 2015-11-12 12:56:09 UTC
I just upgraded to F23 and ended up with gwenview-15.04.2-3.fc23 which is still broken and missing major features due to unmet dependencies. Please, stop pushing kf5 gwenview unless there is kf5 version of libkdcraw and libkipi.

Comment 10 Rex Dieter 2015-11-12 13:31:05 UTC
Sorry about that, looks like a kde4 build had been done, but didn't get included for some reason.  I'll take care of it with an update right away.

Comment 11 Martin Kyral 2015-11-12 13:43:04 UTC
Thanks a lot! Btw. wouldn't it be possible to have the kde4 build as separate package, let's say gwenview4?

Comment 12 Rex Dieter 2015-11-12 13:48:12 UTC
Maybe, but it would require some munging to not conflict, which I'd rather avoid.

Comment 13 Martin Kyral 2015-11-12 13:57:00 UTC
I see.. I hope digikam folks finish the kf5 port of libkdcraw & libkipi soon. IIRC, the announced date for this is december 2015.

Comment 14 Fedora Update System 2015-11-12 15:09:00 UTC
gwenview-4.14.3-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cbfcb59ee

Comment 15 Fedora Update System 2015-11-13 05:29:34 UTC
gwenview-4.14.3-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gwenview'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cbfcb59ee

Comment 16 Fedora Update System 2015-11-23 00:23:36 UTC
gwenview-4.14.3-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Rex Dieter 2016-01-08 14:47:15 UTC
f22/f23 confirmed using kde4 versions now.

Moving forward with moving to kf5 kipi stack for f24


Note You need to log in before you can comment on or make changes to this bug.