Bug 121582 - Postfix rpmbuild MySQL wrong Requires BuildRequires to mysqlclient9
Postfix rpmbuild MySQL wrong Requires BuildRequires to mysqlclient9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
http://http://www.fedora.us/wiki/Post...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-23 11:14 EDT by Alexander Dalloz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 09:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Dalloz 2004-04-23 11:14:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.1)
Gecko/20031114

Description of problem:
The .spec file of the postfix-2.0.16-1 SRPM contains wrong
requirements for runtime and build on mysqlclient9 library while
Fedora Core 1 ships with mysqlclient version 10.

Changing %define MYSQL 0 at top of the .spec file to build Postfix
agains Mysql this causes then build error:

Error: Failed build dependencies                mysqlclient9 is needed
by postfix-2.0.16-1

The .spec file part neede to be changed (lines 99-102):

%if %{MYSQL}
Requires: mysql, mysqlclient9
BuildRequires: mysql, mysqlclient9, mysql-devel
%endif



Version-Release number of selected component (if applicable):
postfix-2.0.16-1

How reproducible:
Always

Steps to Reproduce:
1. get postfix-2.0.16-1.src.rpm
2. rpm ivh postfix-2.0.16-1.src.rpm
3. edit the .spec file and change %define MYSQL 0 to %define MYSQL 1
4. rpmbuild -ba postfix.spec

    

Actual Results:  Error: Failed build dependencies               
mysqlclient9 is needed by postfix-2.0.16-1

Expected Results:  The SRPM and the RPMs should rpmbuild proper with
Postfix build with MySQL support

Additional info:
Comment 1 Thomas Woerner 2004-06-18 09:35:08 EDT
Fixed since 2.0.16-4 in fc2.
Comment 2 Eduardo Figueroa 2004-07-22 05:11:55 EDT
download 
http://download.fedoralegacy.org/redhat/7.3/updates/i386/mysqlclient9-
3.23.22-8.i386.rpm , install it on fedora coe 1 and then try to 
rebuild postfix, It works wonderful for me !!!

Edu.-
Comment 3 Eduardo Figueroa 2004-07-22 05:12:39 EDT
http://download.fedoralegacy.org/redhat/7.3/updates/i386/
Comment 4 Eduardo Figueroa 2004-07-22 05:19:09 EDT
Don't forget to uninstall sendmail first, getting attention not to 
delete dependencies :

rpm -e --nodeps sendmail 

then install postfix !!!!!
I'm so happy.-

Note You need to log in before you can comment on or make changes to this bug.