Bug 121589 - apache gzip compression problems on reload
apache gzip compression problems on reload
Status: CLOSED DUPLICATE of bug 121588
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2004-04-23 12:05 EDT by Paul
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul 2004-04-23 12:05:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
httpd-2.0.48-1.2 php-4.3.4-1.1
vbulletin software used, gzip enabled

Happens when apache is reloaded

Gzip compression turns itself always on when it's supposed to only be
on  on browsers that suppport it.  What happens is when you request
the site, even using wget from the command line, it sends the output
in gzip format which obviously it saves index.html as a bunch of
garbage.   Under normal circumstances this wouldn't happen.  If we
restart the httpd server it fixes the problem. If we reload the httpd
server the problem comes back.  It seems to fix it we have to stop the
server (and wait until all the processes are stopped), then start it.

Now for browsers that support gzip all the way the clients don't
notice it on the site, but for those who don't and those who are using
proxy servers they can't view the site at all unless the 'bug' is
fixed by the restart.

We also noticed that sometimes a reload of httpd will cause the server
to stop working but on rare occasions.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. reload apache
2. request url with gzip enabled and see output (wget)
3. restart apache
4. request url with gzip enabled and see output (wget)

Actual Results:   wget -d -s http://www.hostraiders.com
DEBUG output created by Wget 1.8.2 on linux-gnu.
--11:10:10--  http://www.hostraiders.com/
           => `index.html'
Resolving www.hostraiders.com... done.
Caching www.hostraiders.com =>
Connecting to www.hostraiders.com[]:80... connected.
Created socket 3.
Releasing 0x8918528 (new refcount 1).
---request begin---
GET / HTTP/1.0
User-Agent: Wget/1.8.2
Host: www.hostraiders.com
Accept: */*
Connection: Keep-Alive
---request end---
HTTP request sent, awaiting response... HTTP/1.1 200 OK
Date: Fri, 23 Apr 2004 16:08:15 GMT
Server: Apache/2.0.48 (Fedora)
Accept-Ranges: bytes
Connection: close
Content-Type: text/html; charset=ISO-8859-1
Length: unspecified [text/html]
    [ <=>                                                            
           ] 21,872        20.86M/s
Closing fd 3
11:10:10 (20.86 MB/s) - `index.html' saved [21872]
this is how it should look.. and index.html is in HTML format
when the bug happens, it says GZIP in the header and the index.html is
garbage .. 

Expected Results:  I can't reproduce it right now because it's a
production server but next time it comes up I will (if i can) add to
this post.

Additional info:
Comment 1 Joe Orton 2004-04-29 07:18:46 EDT

*** This bug has been marked as a duplicate of 121588 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.