Bug 121601 - (SND NM256) 2.6.5-1.327 snd-nm256 module hangs Dell Latitidue LS (PP01S)
(SND NM256) 2.6.5-1.327 snd-nm256 module hangs Dell Latitidue LS (PP01S)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-23 14:05 EDT by Dan Williams
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 14:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Don't use workaround on PP01S (1.01 KB, patch)
2004-06-14 12:01 EDT, Dan Williams
no flags Details | Diff
Use nm256 workaround on Latitude CSx too (489 bytes, patch)
2005-05-27 09:58 EDT, Dan Williams
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 158989 None None None Never

  None (edit)
Description Dan Williams 2004-04-23 14:05:25 EDT
using i686 2.6.5-1.327 kernel, anything happening to load the
snd-nm256 module will completely freeze the machine.

Machine is a PIII-500 with NeoMagic MagicMedia256 sound card/GPU.
Comment 1 Dan Williams 2004-04-23 17:38:38 EDT
kernels back to 2.6.5-1.315 also freeze
Comment 2 Alan Cox 2004-05-02 19:44:11 EDT
Arjan - this is almost certainly the Dell audio setup bug that was
fixed in OSS. If you look over the initial setup code in the oss
driver you'll see that over time one I/O was removed because it hangs
Dell laptops
Comment 3 Piers O'Hanlon 2004-05-20 07:29:28 EDT
There's a handily named flag chip->latitude_workaround which isn't
being activated for all Dell Laptops as it has a rather narrow check:
check /sound/pci/nm256/nm256.c:1540

It seems that if one sets the flag to zero then the workaround works?!
Anyway maybe someone should look into making it a wider check or a
module argument that can be set on loading.
Comment 4 Dan Williams 2004-06-14 10:35:43 EDT
For Latitude LS I have:

Subsystem Vendor: 0x1028
Subsystem Device: 0x0080
Comment 5 Dan Williams 2004-06-14 12:01:26 EDT
Created attachment 101116 [details]
Don't use workaround on PP01S
Comment 6 Alan Cox 2004-06-21 08:27:20 EDT
Rediffed and posted upstream
Comment 7 Dan Williams 2004-07-21 14:39:21 EDT
Bug has been fixed for a bit, but patch is verified upstream and in
recent kernels.
Comment 8 Andrew Meredith 2004-11-18 10:22:56 EST
Bug still affects Latitude CSx on kernel 2.6.9-1.667

pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x10c8 device 0x0006
 Neomagic Corporation NM2360 [MagicMedia 256ZX]

pci bus 0x0001 cardnum 0x00 function 0x01: vendor 0x10c8 device 0x8006
 Neomagic Corporation NM2360 [MagicMedia 256ZX Audio]
Comment 9 patrick j. 2005-05-26 19:01:14 EDT
Did you find a workaround for the bug on the CSx?

I have the same problem. I am using the kernel 2.6.11 (CSx).

I have tried the patch provided above, but it doesn't apply on my nm256.c file.
Comment 10 Dan Williams 2005-05-27 09:57:00 EDT
patrick:

Can you try the patch in the next comment instead and see if that seems to fix
the issue?  Could you also post the result of:

lspci | grep Neomagic

Comment 11 Dan Williams 2005-05-27 09:58:15 EDT
Created attachment 114912 [details]
Use nm256 workaround on Latitude CSx too

patrick: can you try to apply this and see if that does anything?
Comment 12 Dan Williams 2005-05-27 10:07:41 EDT
Another interesting reference:
https://bugzilla.ubuntu.com/show_bug.cgi?id=7939
Comment 13 patrick j. 2005-05-27 10:48:08 EDT
Hi Dan,

The patch could be applied successfuly. I am presently compiling the kernel. I
let you know if that fix the problem.

The result of the command is:

# lspci | grep Neomagic
0000:01:00.0 VGA compatible controller: Neomagic Corporation NM2360 [MagicMedia
256ZX]
0000:01:00.1 Multimedia audio controller: Neomagic Corporation NM2360
[MagicMedia 256ZX Audio]
Comment 14 Dan Williams 2005-05-27 10:53:27 EDT
patrick:

Could you also now post the output of "lspci -n" as well so I can be sure the
Neomagic device numbers are correct for the patch I posted?

Thanks!
dan
Comment 15 Andrew Meredith 2005-05-27 10:59:28 EDT
I have since shifted the Latitude CSx mentioned above to RHEL 4 WS with kernel
2.6.9-5.0.5.EL and the problem still exists. With RHEL 4 WS being a flagship
product and Dell being a favoured partner, this does seem a little sad.

As a subscriber I have raised this against RHEL 4 as bug number 158989

Comment 16 patrick j. 2005-05-27 11:06:26 EDT
Dan:

Here is the result of the command:

# lspci -n
0000:00:00.0 Class 0600: 8086:7190 (rev 03)
0000:00:01.0 Class 0604: 8086:7191 (rev 03)
0000:00:03.0 Class 0607: 104c:ac1c (rev 01)
0000:00:03.1 Class 0607: 104c:ac1c (rev 01)
0000:00:07.0 Class 0680: 8086:7110 (rev 02)
0000:00:07.1 Class 0101: 8086:7111 (rev 01)
0000:00:07.2 Class 0c03: 8086:7112 (rev 01)
0000:00:07.3 Class 0680: 8086:7113 (rev 03)
0000:01:00.0 Class 0300: 10c8:0006
0000:01:00.1 Class 0401: 10c8:8006
Comment 17 Dan Williams 2005-05-27 14:17:39 EDT
patrick: did this patch end up fixing the issue?
Comment 18 patrick j. 2005-05-29 06:04:42 EDT
dan:

I don't think so. I still get freeze at startup. Did it work for you?
Comment 19 patrick j. 2005-06-15 01:28:53 EDT
Bump. ;)
Comment 20 Dan Williams 2005-06-15 14:52:33 EDT
Hmm, I'm kind of out of ideas on this one then...  without the specific hardware
its a bit hard to nail down.

One more thing though, can you try setting "vaio_hack=1" as a module parameter.
 Does that help at all?  The vaios that setting is supposed to be for also have
the ZX chip.

Note You need to log in before you can comment on or make changes to this bug.