This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 121613 - TCP based fontpaths do not work properly
TCP based fontpaths do not work properly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-23 16:38 EDT by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 03:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/fs/config (1.40 KB, text/plain)
2004-04-23 16:39 EDT, Enrico Scholz
no flags Details
/etc/X11/XF86Config (3.37 KB, text/plain)
2004-04-23 16:41 EDT, Enrico Scholz
no flags Details
/var/log/Xorg.0.log (45.50 KB, text/plain)
2004-04-23 16:42 EDT, Enrico Scholz
no flags Details

  None (edit)
Description Enrico Scholz 2004-04-23 16:38:12 EDT
Description of problem:

I am using an external fontserver and configured xorg-x11 with

|    FontPath        "tcp/font-server.ultra.csn.tu-chemnitz.de.:7100"

('font-server' is another machine connected by ethernet)


After some time (or arbitrary actions), the connection seems to break
and 'xlsfonts' does not find fonts anymore:

| $ xlsfonts  | wc
|    6910   11524  421440

... doing something (starting programs, moving windows) ...

| $ xlsfonts  |wc
| xlsfonts: pattern "*" unmatched
|       0       0       0



After a recovery with 'xset fp= /usr/../fonts && xset fp default'
things are working for a short time until the disconnect occurs again.

The xfs fontserver seems to be ok: it is still alive after sending a
last TCP packet and waits for a response from the Xserver (which does
not respond). Neither the XFS-, nor the Xserver gives any error-message
or warning.


This seems to be related with the TCP setup: when running XFS locally
with the same settings+font-data, but 'unix/:7100', I can not reproduce
it anymore.

The same setup (with the TCP-fontpath) worked fine with XFree86-4.3.0-64
and previous versions; I see the problems since the change to xorg-x11.



Version-Release number of selected component (if applicable):

xorg-x11-6.7.0-0.5
Comment 1 Enrico Scholz 2004-04-23 16:39:17 EDT
Created attachment 99657 [details]
/etc/X11/fs/config
Comment 2 Enrico Scholz 2004-04-23 16:41:05 EDT
Created attachment 99658 [details]
/etc/X11/XF86Config
Comment 3 Enrico Scholz 2004-04-23 16:42:49 EDT
Created attachment 99659 [details]
/var/log/Xorg.0.log

sorry... running of official Fedora packages (xorg-x11 + 2.6 kernel) is not
possible
Comment 4 Mike A. Harris 2004-05-06 01:15:32 EDT
If this problem can be reproduced and confirmed on a Fedora Core 2
test3 or later updated system using our official binary packages and
kernel 2.6.x, we can troubleshoot this problem a bit deeper.

Alternatively, if you're unable to use FC2 with kernel 2.6.x on this
particular system, it would be just as useful to have confirmation
of the problem on a different system or from other Fedora Core users
which are using an official Fedora Core 2 kernel and binary rpms.

Once this is confirmed, please attach the same data as above to the
report from the system that is able to reproduce the problem.  This
data will be useful for comparison with the above data, and may
shed additional light into the issue as well.

Another thing that has occured to me which may be useful, is wether
or not there is a firewall or router between the font server machine
and the client machine, and wether or not the traffic is going
through IP masquerading or other NAT?

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.