Bug 1216234 - GET /api/v2/locations/:id does not return information about realms
Summary: GET /api/v2/locations/:id does not return information about realms
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Chris Duryee
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1230873 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-28 20:19 UTC by jaudet
Modified: 2019-09-25 20:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:50:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 10357 None None None 2016-04-22 15:33:56 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description jaudet 2015-04-28 20:19:17 UTC
Description of problem:
A location can be associated with zero or more realms. The API documentation makes mention of this in the documentation for POST /api/v2/locations and PUT /api/v2/locations/:id, and the UI exposes this capability too. (See the relevant API documentation page at https://sat.example.com/apidoc/v2/locations.html and search for "realm".) However, a GET request to /api/v2/locations/:id will return information about associated realms.

Version-Release number of selected component (if applicable):
Tested against Satellite-6.1.0-RHEL-6-20150424.0 and Satellite-6.1.0-RHEL-7-20150424.0.

How reproducible:
100%

Steps to Reproduce:
1. Issue an HTTP GET request to https://sat.example.com/api/v2/locations/:id
2. Examine the response.
3. Discover that realms are not mentioned.

Actual results:

    [
        u'compute_resources',
        u'config_templates',
        u'created_at',
        u'description',
        u'domains',
        u'environments',
        u'hostgroups',
        u'id',
        u'media',
        u'name',
        u'organizations',
        u'parameters',
        u'select_all_types',
        u'smart_proxies',
        u'subnets',
        u'title',
        u'updated_at',
        u'users',
    ]

Expected results:
Same as above, but with realms mentioned.

Additional info:

Comment 1 RHEL Program Management 2015-04-28 20:33:21 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 jmagen@redhat.com 2015-05-03 12:53:33 UTC
Yes, bug. Realms should have been added to API response for locs/orgs when introduced

Comment 4 Bryan Kearney 2015-05-04 13:40:27 UTC
Created redmine issue http://projects.theforeman.org/issues/10357 from this bug

Comment 5 Bryan Kearney 2015-08-25 18:35:20 UTC
Upstream bug component is Multi Org

Comment 6 Bryan Kearney 2015-12-02 20:07:00 UTC
*** Bug 1230873 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2016-01-12 09:10:08 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10357 has been closed
-------------
Ondřej Pražák
Applied in changeset commit:502feabe1259186625453a9dcc2165ccd0292741.

Comment 12 errata-xmlrpc 2016-07-27 08:50:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.