Bug 121626 - kernel-sources rpm erased old kernel and grub
kernel-sources rpm erased old kernel and grub
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: 124619
  Show dependency treegraph
 
Reported: 2004-04-23 20:10 EDT by Diego
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 11:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Diego 2004-04-23 20:10:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I installed FC2 (1.91) and then updated throught RPM's my kernel to
the one suggested by up2date and after doing the kernel-sources
install it erased my old kernel in /boot and did not update
/etc/grub.conf correctly.

It finished the install with grubby sending a message that a template
could not be found. 

I tried installing with enforcing and without enforcing and both times
the same result.

Version-Release number of selected component (if applicable):
kernel-source-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 1.91
2. up2date --install kernel kernel-source kernel-utils
3. reboot
    

Actual Results:  Couldn't log to the machine

Expected Results:  Both new and old kernels installed

Additional info:

I tried on a 920CA Presario laptop with nothing extra
Comment 1 Arjan van de Ven 2004-04-28 07:21:39 EDT
this is odd but I doubt it's caused by kernel-source; more likely
up2date did an rpm -U equivalent on the kernel...
Comment 2 Matthew Miller 2005-04-26 12:23:03 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 3 David Lawrence 2006-04-18 16:14:38 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.
Comment 4 John Thacker 2006-04-22 11:06:49 EDT
up2date is no longer shipped with Fedora Core; it's functionality 
has been replaced by pup, found in the pirut package.  The only fixes 
likely to be made to up2date in RedHat Linux and earlier Fedora Core 
versions are security fixes by Fedora Legacy.  This does not seem to 
be a security bug, so I'm closing it.

If the problem is appropriate to RHEL and occurs to a user there, it 
can be filed as such.

Note You need to log in before you can comment on or make changes to this bug.