Bug 121633 - RPM cvs HEAD fails to build on glibc-2.3.4 system with nptl
RPM cvs HEAD fails to build on glibc-2.3.4 system with nptl
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 01:26 EDT by Joseph Tate
Modified: 2007-04-18 13:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 18:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pthread.h from glibc 2.3.4 (33.20 KB, text/plain)
2004-04-24 01:28 EDT, Joseph Tate
no flags Details
Patch to fix build problem (694 bytes, patch)
2004-04-24 01:29 EDT, Joseph Tate
no flags Details | Diff
rollup.patch (2.59 KB, patch)
2004-04-24 03:12 EDT, Joseph Tate
no flags Details | Diff

  None (edit)
Description Joseph Tate 2004-04-24 01:26:10 EDT
Description of problem: 
RPM HEAD fails to build on glibc because of a difference in the way 
pthread.h defines pthread_cleanup_push and pthread_cleanup_pop. 
 
Version-Release number of selected component (if applicable): 
CVS HEAD 
 
I'll attach a copy of my pthread.h and a patch that allows it to 
compile.
Comment 1 Joseph Tate 2004-04-24 01:28:00 EDT
Created attachment 99672 [details]
pthread.h from glibc 2.3.4

As promised, a copy of pthread.h from glibc-2.3.4
Comment 2 Joseph Tate 2004-04-24 01:29:50 EDT
Created attachment 99673 [details]
Patch to fix build problem

This patch fixes the mentioned build problem.
Comment 3 Joseph Tate 2004-04-24 03:09:36 EDT
There are a few more things that I had to do to get this to work 
right.  I'll attach a rollup patch. 
 
I also had issues with libedl.so on the 'make check' stage: I 
noticed that the "install:" target for the makefile had all the 
commands commented out within that directory. 
 
The autogen.sh and Makefile.in force the user to use the bundled 
"file" package. 
 
So, as I see it, there are a number of bugs: 
1.   Unable to use external 'file'. 
2.   libelf compile failure (fixed by rollup.patch) 
3.   no determination of selinux (fixed by rollup.patch) 
4.   compile error in rpmio/rpmsq.c due to new pthread.h (fixed in 
rollup.patch) 
5.   Bad INSTALL documentation of commands needed for tarball based 
install (fixed in rollup.patch) 
6.   make check fails when using bundled libelf. 
 
Comment 4 Joseph Tate 2004-04-24 03:12:37 EDT
Created attachment 99674 [details]
rollup.patch

As mentioned in my last comment, this patch fixes.
1) compile failure in libelf/tests/
2) autogen.sh not recognizing a non-selinux system
3) compile error in rpmio/rpmsq.c in conjunction with glibc-2.3.4.
4) INSTALL file omission.
Comment 5 Jeff Johnson 2005-02-07 18:18:54 EST
1) internal elfutils is not current and should not be used
for any serious work. what is there is useful for rpm development
because the internal AOPI includes are annotated and so
splint can be used to detect problems while developming.

2) forcing selinux build failure is the desired default
build path for RH rpm. This has been fixed in other
ways on ehad and rpm-4_4 branches of rpm.

3) fixed afaik in rpm-4.4.1-0.18 and later.

4) inclusion of -p or not doesn't look like a serious documentation
flaw. /var/lock/rpm is now in /var/lib/rpm and is a configurable
macro.

Thanks for the patches however, apologies for the long delay.

Note You need to log in before you can comment on or make changes to this bug.