Bug 12164 - exception in timezone_gui.py
exception in timezone_gui.py
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 16:55 EDT by James Manning
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-26 21:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2000-06-12 16:55:29 EDT
While in Time Zone selection, I left the defaults for "Location"
(since they're correct), hit the "UTC Offset" tab to check it out
(noticed it had Daylight Saving Time defaulting to off, and it's
actually spelled "Savings" afaik). Noticed it seemed ok and hit the
Location tab again to switch back when the following exception occurred:

Traceback (innermost last):
  File "/usr/lib/anaconda/gui.py", line 176, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2538, in mainloop
    __gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 100, in setcurrent
    self.tz.setcurrent(self.default)
SystemError: NULL result without error in call_object

Machine is a standard Netfinity 3500 (dual 333) using the on-board
adaptec, installing to second scsi drive.
Comment 1 Brock Organ 2000-06-26 17:24:37 EDT
hmmm ... I cannot reproduce this behavior in test ...

does this still occur using beta2 ...?
Comment 2 James Manning 2000-06-26 21:00:20 EDT
You can't reproduce it since it was fixed already (and I wish that this bug
would have been changed to reflect that earlier, but I guess msw's busy :)

--- anaconda-beta1/iw/timezone_gui.py    Tue Jun  6 01:40:59 2000
+++ anaconda-beta2/iw/timezone_gui.py    Tue Jun 20 03:19:36 2000
@@ -97,7 +97,10 @@
             self.ics.setNextEnabled (TRUE)
 
     def setcurrent (self, widget, area):
-        self.tz.setcurrent (self.default)
+        try:
+            self.tz.setcurrent (self.default)
+        except SystemError:
+            pass
         widget.disconnect (self.id)
         
     def getScreen (self):

Note You need to log in before you can comment on or make changes to this bug.