Bug 121647 - (DRI ?)Radeon 7000 GDM restarts with .2188 kernel
Summary: (DRI ?)Radeon 7000 GDM restarts with .2188 kernel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-24 13:53 UTC by Colin Charles
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 06:55:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Colin Charles 2004-04-24 13:53:50 UTC
Description of problem: X session has crashed, while the machine is
running idle, with Xscreensaver being active. GDM restarts and I'm
placed with a login screen, with all other running X apps dead.


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2188.nptl
XFree86-4.3.0-55
gdm-2.4.4.5-1.2

How reproducible:
So far, this has only happened once - looks like a screensaver within
the xscreensaver package that is causing grief. Only noticed after the
new kernel upgrade.

Steps to Reproduce:
1. Leave machine idle
2. Xscreensaver starts
3. (Xscreensaver possibly hits a buggy screensaver)
4. GDM crashes
  
Actual results:
GDM restarts, placing me at the login screen. All work in X that was
running earlier has been lost

Expected results:
Xscreensaver showing the password unlock screen

Additional info: relevant extract from /var/log/messages
Apr 24 13:27:06 albus gdm[5037]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Apr 24 13:27:11 albus kernel: [drm:radeon_unlock] *ERROR* Process
20263 using kernel context 0
Apr 24 13:28:40 albus gconfd (byte-4709): GConf server is not in use,
shutting d own.
Apr 24 13:28:40 albus gconfd (byte-4709): Exiting

Process 20263 is: 
root     20263 19.5 11.7 132060 60356 ?      S    Apr24 124:10
/usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7

Comment 1 Colin Charles 2004-06-15 06:55:19 UTC
This appears to have been fixed, so am closing it.


Note You need to log in before you can comment on or make changes to this bug.