Bug 121649 - typo in sk_g16.c kernel source
typo in sk_g16.c kernel source
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 11:27 EDT by Brian Smith
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 02:42:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Smith 2004-04-24 11:27:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
In /usr/src/linux/drivers/net/sk_g16.c it causes a make modules to
fail with compiler error.

The fix is to change sb to skb on line 1285 from:
  memcpy_toio((tmdp->u.buffer & 0x00ffffff) + sb->len, pad, len-skb->len);
to:
  memcpy_toio((tmdp->u.buffer & 0x00ffffff) + skb->len, pad,
len-skb->len);

Granted this is minor, and I don't use this driver, but someone might. :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /usr/src/linux
2. make modules


    

Actual Results:  compiler error

Expected Results:  all modules made w/o error

Additional info:
Comment 3 Ernie Petrides 2005-03-02 13:23:57 EST
Hello, Brian.  A fixed version of that driver is upstream in 2.6.  But
the version whose source is included in RHEL3 is obsolete and is not
built in RHEL3 distributions because CONFIG_OBSOLETE is not enabled.

Note You need to log in before you can comment on or make changes to this bug.