Bug 121651 - NFS remote quota server being stopped even when disabled
NFS remote quota server being stopped even when disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
1
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 11:38 EDT by Erik Karu
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 06:42:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NFS init script fix for NFS quotas (353 bytes, patch)
2004-04-24 11:39 EDT, Erik Karu
no flags Details | Diff

  None (edit)
Description Erik Karu 2004-04-24 11:38:10 EDT
Description of problem:
I've disabled NFS remote quota server by adding line

RQUOTAD=no

to the NFS configuration file /etc/sysconfig/nfs. However, when NFS is
being shutdown, an error is printed as the setting is not checked!

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-1

How reproducible:
Always.

Steps to Reproduce:
1. echo "RQUOTAD=no" > /etc/sysconfig/nfs
2. /etc/init.d/nfs restart
3. /etc/init.d/nfs restart
  
Actual results:
Shutting down NFS quotas:                                  [FAILED]


Expected results:
No message printed at all, since NFS quota is disabled.

Additional info:
The attached patch fixes the problem by doing the same check in the
stop) section as what is done in the start) section of
/etc/init.d/nfs. Please apply.
Comment 1 Erik Karu 2004-04-24 11:39:55 EDT
Created attachment 99676 [details]
NFS init script fix for NFS quotas

Obvious patch to fix the problem.
Comment 2 Erik Karu 2004-06-07 15:57:50 EDT
What's up with this? Should be trivial and applies to FC2 also!

Note You need to log in before you can comment on or make changes to this bug.