Bug 121670 - Compile bug
Compile bug
Status: CLOSED DUPLICATE of bug 115282
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-24 23:30 EDT by John Morris
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Morris 2004-04-24 23:30:11 EDT
Description of problem:

I'm building i386 packages on x86_64 by creating a chroot environment
with a full i386 packageset.  All but two of the srpms from RHEL3 will
successfully rebuild in this way, gcc being one of the failures.

Version-Release number of selected component (if applicable):

gcc-3.2.3-20.src.rpm


How reproducible:

Always

Steps to Reproduce:
1.  Build up a chroot environment of RHEL3 while running the x86_64
kernel.
2.  Attempt rebuilding gcc-3.2.3-20.src.rpm.
3.  Watch it fail.
4.  Reboot into an i386 environment, plug back into the same chrooted
environment and repeat.  It will succeed.

I am doing all of the proper steps to create a full chrooted build
environment.  /proc, /dev/pts and /dev/shm are being mounted and a
setarch i386 is being done in front of the chroot command.  The script
used to create the chroot is available if needed.
  
Actual results:

Comparing captures of the build, things go wrong here:

checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking whether gcc and cc understand -c and -o together... yes
checking for gnatbind... gnatbind
checking for compiler driver that understands Ada... no

Expected results:

When building with an athlon kernel I get this correct output:

checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking whether gcc and cc understand -c and -o together... yes
checking for gnatbind... gnatbind
checking for compiler driver that understands Ada... gcc

I really tried to track down what is going wrong in more detail, but I
just can't make heads or tails out of the GCC spec file, to say
nothing of the actual configure script for that puppy.
Comment 1 John Morris 2004-05-01 20:50:15 EDT

*** This bug has been marked as a duplicate of 115282 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.