Bug 121674 - Locale not supported by locale.
Locale not supported by locale.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-25 07:12 EDT by Manish Regmi
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-14 06:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manish Regmi 2004-04-25 07:12:45 EDT
Description of problem: Cannot use locale Nepali. When i choose the 
locale to nepali(LC_np).  It says locale not supported by Xlib.



Version-Release number of selected component (if applicable):
Fedore core 2 test 2


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alan Cox 2004-05-02 19:35:59 EDT
Glibc doesn't seem to include np in the locale definitions. You need a
glibc locale definition for nepali and then possibly X and gdm
definitions 
Comment 3 Ulrich Drepper 2004-05-04 12:33:08 EDT
Where does LC_np come from.  This is wrong for multiple reasons: the
language code "LC" does not exit, it's written in uppercase (instead
of lowercase), "np" is in lowercase (instead of uppercase).

If ne_NP would be used it works.  At least in FC2, don't know when
this locale was added.
Comment 4 Mike A. Harris 2004-05-04 14:56:00 EDT
Thanks Uli.

Closing bug as 'NOTABUG' - incorrect locale usage.
Comment 5 Ulrich Drepper 2004-05-04 15:14:40 EDT
This is not necessarily NOTABUG.  Somebody has to check where this
incorrect locale name comes from.  If it is automatically listed in
the gdm login screen something *is* wrong.
Comment 6 Mike A. Harris 2004-05-04 15:19:29 EDT
Ok, reopening.

Manish) How are you selecting this locale?
Comment 7 Manish Regmi 2004-05-04 21:50:15 EDT
Sorry for listing incorrect name. It is actually ne_NP. I choose that 
during the login. 
 I didnt showed anything in nepali. Then I ran nautilus from the 
terminal. It said 

locale not supported by Xlib.

thanks.

Comment 8 Ulrich Drepper 2004-05-04 22:31:40 EDT
Do you have a directory

  /usr/lib/locale/ne_NP

and files like LC_CTYPE in it?  If yes, it's a matter of adding the
voodoo in /usr/lib/X11/locale/locale.dir.  Try adding a line like

en_US.UTF-8/XLC_LOCALE:                 ne_NP.UTF-8

to that file.
Comment 9 Manish Regmi 2004-05-05 03:20:09 EDT
hi,
 There is a directory /usr/lib/locale/ne_NP and there are also files 
like LC_CTYPE in it. I looked in the /usr/lib/X11/locale/locale.dir. 
I added the line 
en_US.UTF-8/XLC_LOCALE:                 ne_NP.UTF-8

Now the warning message problem is solved. But i cannot see 
characters in Nepali in Nautilus. Further, the characters are 
invisible. I cannot see menubar but the files and folders are visible
(in English). I can only see Places menu(in english).

Same problem with gedit.

thanks.
Comment 10 Manish Regmi 2004-07-27 03:03:26 EDT
hi,
 Same Problem with FC2. IS anybody working on that???
Comment 11 Mike A. Harris 2004-08-14 06:15:32 EDT
Please report this problem to X.Org upstream at the following bugzilla
address:  http://bugs.freedesktop.org - against the xorg component.

Once upstream has reviewed this request and integrated this into
X.Org CVS, it will be included in X.Org 6.8.0 or later, and will
eventually make it into Fedora Core.

Once you've filed your report upstream, please paste the URL here, and
we will monitor the upstream report, and consider backporting support
to currently supported Fedora Core releases.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.