Bug 121677 - snd-pcm-oss module not being loaded
snd-pcm-oss module not being loaded
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: modutils (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-25 08:46 EDT by Thomas Molina
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 12:45:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/modprobe.conf as requested (303 bytes, text/plain)
2004-04-27 17:08 EDT, Thomas Molina
no flags Details
/etc/modprobe.conf.dist as requested (5.35 KB, text/plain)
2004-04-27 17:09 EDT, Thomas Molina
no flags Details

  None (edit)
Description Thomas Molina 2004-04-25 08:46:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
My system has a Yamaha ymf754 chip on the soundcard which uses the
ymfpci driver.  At bootup, all the sound modules are auto loaded
except the snd-pcm-oss module.  Instead, the system incorrectly loads
the snd-pcm module.  There is no sound in this case.  In order to make
sound come up properly I need to manually load snd-pcm-oss and rerun
aumix -L -f /etc/.aumixrc.  

How reproducible:
Always
Comment 1 Thomas Molina 2004-04-25 13:28:51 EDT
This behaviour continues through the updates which bring the system up
to test3.
Comment 2 Bill Nottingham 2004-04-27 16:56:37 EDT
Please attach /etc/modprobe.conf and /etc/modprobe.conf.dist.
Comment 3 Thomas Molina 2004-04-27 17:08:41 EDT
Created attachment 99726 [details]
/etc/modprobe.conf as requested
Comment 4 Thomas Molina 2004-04-27 17:09:25 EDT
Created attachment 99727 [details]
/etc/modprobe.conf.dist as requested
Comment 5 Bill Nottingham 2004-04-27 17:25:19 EDT
Change sound-slot-0 to snd-card-0 in /etc/modprobe.conf. Does it all
work then?
Comment 6 Thomas Molina 2004-04-27 19:38:51 EDT
No.  However, changing snd-mixer-pcm to snd-pcm-oss in
modprobe.conf.dist does cause snd-pcm-oss to load.  Since snd-pcm-oss
has a dependency on snd-mixer-oss, both load.  

However, in any of the above situations I don't get actual sound until
I log out and log back in.  I'm not sure what that is all about.
Comment 7 Thomas Molina 2004-05-13 19:40:52 EDT
I am still not getting the snd-mixer-pcm module loaded.  However, I am
getting snd-pcm module loaded.  In any case, I don't get actual sound
until after the first time I log in and log back out again.
Comment 8 Bill Nottingham 2004-05-19 17:54:39 EDT
Does it work with the final FC2?
Comment 9 Thomas Molina 2004-05-22 22:09:18 EDT
I just loaded the final FC2 and I do get sound with no problems. 
Thanks.  This bug can be closed as far as I am concerned.

Note You need to log in before you can comment on or make changes to this bug.