Bug 121680 - CVS 1.11.15-1 _REGRESSION_
CVS 1.11.15-1 _REGRESSION_
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-25 10:05 EDT by Guðmundur D. H.
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 14:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guðmundur D. H. 2004-04-25 10:05:45 EDT
Description of problem:
Since I upgraded to cvs-1.11.15-1 my CVS server has not worked
correctly. The server does not allow logins, writing a message to
/var/log/messages:

cvs: login refused for /home/cvs/XXXX

I run cvs from xinetd, and the configuration for it is like this: 

service cvspserver 
{
	disable	= no
	server		= /usr/bin/cvs
	server_args	= -f --allow-root=/home/cvs/XXX1/
--allow-root=/home/cvs/XXX2/ --allow-root=/home/cvs/XXX3/ pserver  
	protocol	= tcp
	user		= cvs
	wait		= no 
	socket_type	= stream
}                                          

NOTE: This configuration worked before the update (last night!).

Version-Release number of selected component (if applicable):
1.11.15-1

How reproducible:
Upgrade from stock FC1 CVS (cvs-1.11.5-3) to cvs-1.11.15-1.
Comment 1 Guðmundur D. H. 2004-04-25 10:07:22 EDT
I tried using an old client (e.g. cvs-1.11.1p1-8.7) and that works...

So use the 1.11.15-1 client.
Comment 2 Guðmundur D. H. 2004-04-25 11:42:37 EDT
ok, a bit more info ... (sorry for the spam...) 

cvs logout and cvs update do not work, but cvs commit seams to work
(at least, sometimes).

Just for the reference; I'm using this form of commands: 
cvs -d :pserver:username@host:/home/cvs/XXX/ command

E.g.: cvs -d :pserver:username@host:/home/cvs/XXX/ checkout 

-G.
Comment 3 Guðmundur D. H. 2004-05-23 14:56:22 EDT
This issue is also present with Fedora Core 2, updating.
Comment 4 Guðmundur D. H. 2004-05-23 17:31:26 EDT
The WinCVS client is also having problems using this CVS server.

Is anyone reading or working on this anyway?
Comment 5 Guðmundur D. H. 2004-05-23 22:01:19 EDT
Using a newer version of cvsnt and adding a --allow-root=path=path
without a ending slash (!) to cvs parameters solves the problem with
WinCVS.


Comment 6 Eido Inoue 2004-10-29 14:37:30 EDT
cvsnt seems to be at fault here, not cvs.
Comment 7 Guðmundur D. H. 2004-10-29 18:18:07 EDT
> cvsnt seems to be at fault here, not cvs.

Read again; I'm reporting a bug in the CVS package shipped with FC2
and in FC1 updates. This happens when it's acting like a server and
it's client module is accessing the server's resources.

Additionally, this happens ALSO when the cvsnt client uses it as it's
server.

Any hints or comments are welcome.

Thank you, 
Guðmundur.
Comment 8 Eido Inoue 2004-11-01 11:25:41 EST
sorry, unable to reproduce given the environment you provided me
(obviously, i changed the --allow-root params and simulated a CVS
server... i obviously can't replicate your cvs tree) with current FC2
client. (assuming you mean FC2 1.11.17-2)

Note You need to log in before you can comment on or make changes to this bug.