Bug 1216897 - Files from kcm_touchpad conflicts with files from plasma-desktop
Summary: Files from kcm_touchpad conflicts with files from plasma-desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1216262 1216977 1217190 1217308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-29 07:17 UTC by Swâmi Petaramesh
Modified: 2015-05-10 19:20 UTC (History)
14 users (show)

Fixed In Version: powerdevil-5.3.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 16:40:28 UTC


Attachments (Terms of Use)

Description Swâmi Petaramesh 2015-04-29 07:17:07 UTC
Description of problem:

Trying to "dnf update" my Fedora 22 beta this morning results in file conflicts between kcm_touchpad and plasma-desktop

Erreur : Erreur du contrôle de transaction
  file /usr/bin/kcm-touchpad-list-devices from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/lib64/qt5/plugins/kded_touchpad.so from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/lib64/qt5/plugins/plasma/dataengine/plasma_engine_touchpad.so from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/knotifications5/kcm_touchpad.notifyrc from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/kservices5/kcm_touchpad.desktop from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/kservices5/kded/touchpad.desktop from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/kservices5/plasma-applet-touchpad.desktop from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/kservices5/plasma-dataengine-touchpad.desktop from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64
  file /usr/share/plasma/plasmoids/touchpad/metadata.desktop from install of kcm_touchpad-5.1.95-1.fc22.x86_64 conflicts with file from package plasma-desktop-5.3.0-1.fc22.x86_64


Version-Release number of selected component (if applicable):
- desktop-5.3.0-1.fc22.x86_64
- kcm_touchpad-5.1.95-1.fc22.x86_64


How reproducible:

100% reproductible ;-)


Steps to Reproduce:
Update system, or try to install both...

Actual results:
Fails

Expected results:
Works ;-)

Comment 1 Daniel Vrátil 2015-04-29 09:06:18 UTC
Fixed by plasma-desktop-5.3.0-2.fc22 (currently in pending for [updates-testing])

Comment 2 Rex Dieter 2015-04-29 10:51:50 UTC
*** Bug 1216977 has been marked as a duplicate of this bug. ***

Comment 3 Maarten 2015-04-29 10:52:38 UTC
dnf remove kcm_touchpad works for me (since I have no touchpad)

Comment 4 Jan Grulich 2015-04-29 18:22:31 UTC
*** Bug 1217190 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-04-29 19:12:09 UTC
powerdevil-5.3.0-1.fc22, kmenuedit-5.3.0-1.fc22, kdeplasma-addons-5.3.0-1.fc22, plasma-oxygen-5.3.0-1.fc22, libksysguard-5.3.0-1.fc22, kwrited-5.3.0-1.fc22, kf5-kfilemetadata-5.9.0-1.fc22, khelpcenter-5.3.0-1.fc22, khotkeys-5.3.0-1.fc22, sddm-kcm-5.3.0-1.fc22, libkscreen-qt5-5.3.0-1.fc22, polkit-kde-5.3.0-1.fc22, plasma-workspace-wallpapers-5.3.0-1.fc22, ksysguard-5.3.0-1.fc22, kio-extras-5.3.0-1.fc22, kdecoration-5.3.0-1.fc22, kf5-baloo-5.9.0-1.fc22, kde-cli-tools-5.3.0-1.fc22, plasma-breeze-5.3.0-1.fc22, kscreen-5.3.0-1.fc22, ksshaskpass-5.3.0-1.fc22, plasma-sdk-5.3.0-1.fc22, kf5-kwayland-5.3.0-1.fc22, kinfocenter-5.3.0-1.fc22, plasma-systemsettings-5.3.0-1.fc22, plasma-nm-5.3.0-1.fc22, plasma-milou-5.3.0-1.fc22, oxygen-fonts-5.3.0-1.fc22, kwin-5.3.0-2.fc22, plasma-desktop-5.3.0-3.fc22, plasma-workspace-5.3.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-7070/oxygen-fonts-5.3.0-1.fc22,powerdevil-5.3.0-1.fc22,plasma-workspace-5.3.0-3.fc22,plasma-desktop-5.3.0-3.fc22,kio-extras-5.3.0-1.fc22,kmenuedit-5.3.0-1.fc22,kdecoration-5.3.0-1.fc22,kdeplasma-addons-5.3.0-1.fc22,kf5-baloo-5.9.0-1.fc22,plasma-oxygen-5.3.0-1.fc22,kde-cli-tools-5.3.0-1.fc22,libksysguard-5.3.0-1.fc22,kwin-5.3.0-2.fc22,kwrited-5.3.0-1.fc22,plasma-breeze-5.3.0-1.fc22,kf5-kfilemetadata-5.9.0-1.fc22,kscreen-5.3.0-1.fc22,khelpcenter-5.3.0-1.fc22,ksshaskpass-5.3.0-1.fc22,khotkeys-5.3.0-1.fc22,plasma-sdk-5.3.0-1.fc22,sddm-kcm-5.3.0-1.fc22,kf5-kwayland-5.3.0-1.fc22,libkscreen-qt5-5.3.0-1.fc22,kinfocenter-5.3.0-1.fc22,polkit-kde-5.3.0-1.fc22,plasma-systemsettings-5.3.0-1.fc22,plasma-workspace-wallpapers-5.3.0-1.fc22,plasma-nm-5.3.0-1.fc22,ksysguard-5.3.0-1.fc22,plasma-milou-5.3.0-1.fc22

Comment 6 satellitgo 2015-04-29 22:00:04 UTC
seen in f22-kde-live i686 -TC-1 live install to VirtualBox
dnf update fails

Comment 7 Nick Coghlan 2015-04-29 22:59:23 UTC
Interim workaround for me was:

    sudo dnf remove kcm_touchpad
    sudo dnf install xcb-util-cursor # Removed by previous command
    sudo dnf update -y

The touchpad is currently still working, presumably due to the conflicting files currently included in the plasma-desktop RPM.

However, I'm not seeing the update showing up locally, despite clearing the DNF caches.

I'm assuming it's a problem with the mirrors, so once it gets out of the moderation queue, I have a question about that here: https://ask.fedoraproject.org/en/question/67924/bypassing-mirrors-during-beta-cycle/

Comment 8 Joachim Backes 2015-04-30 07:34:36 UTC
Solved for me by downloading and installing plasma-desktop-5.3.0-3.fc22.x86_64 from koji.

Comment 9 Jan Grulich 2015-04-30 09:04:12 UTC
*** Bug 1217308 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-05-01 16:40:28 UTC
powerdevil-5.3.0-1.fc22, kmenuedit-5.3.0-1.fc22, kdeplasma-addons-5.3.0-1.fc22, plasma-oxygen-5.3.0-1.fc22, libksysguard-5.3.0-1.fc22, kwrited-5.3.0-1.fc22, kf5-kfilemetadata-5.9.0-1.fc22, khelpcenter-5.3.0-1.fc22, khotkeys-5.3.0-1.fc22, sddm-kcm-5.3.0-1.fc22, polkit-kde-5.3.0-1.fc22, plasma-workspace-wallpapers-5.3.0-1.fc22, ksysguard-5.3.0-1.fc22, kio-extras-5.3.0-1.fc22, kdecoration-5.3.0-1.fc22, kf5-baloo-5.9.0-1.fc22, kde-cli-tools-5.3.0-1.fc22, plasma-breeze-5.3.0-1.fc22, kscreen-5.3.0-1.fc22, ksshaskpass-5.3.0-1.fc22, plasma-sdk-5.3.0-1.fc22, kf5-kwayland-5.3.0-1.fc22, kinfocenter-5.3.0-1.fc22, plasma-systemsettings-5.3.0-1.fc22, plasma-nm-5.3.0-1.fc22, plasma-milou-5.3.0-1.fc22, oxygen-fonts-5.3.0-1.fc22, kwin-5.3.0-2.fc22, plasma-desktop-5.3.0-3.fc22, plasma-workspace-5.3.0-3.fc22, libkscreen-qt5-5.3.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 satellitgo 2015-05-01 16:53:31 UTC
not seen in f22 plasma TC-1 live install x86_64
automatic updates when selected updates successfully.
Also Apper updates successfully in Apper test day tests.

Comment 12 Rex Dieter 2015-05-10 19:20:40 UTC
*** Bug 1216262 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.