Bug 121690 - Flash plugin for Mozilla stops working when in enforcing mode
Flash plugin for Mozilla stops working when in enforcing mode
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-04-25 18:02 EDT by Jacob Kroon
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-14 17:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jacob Kroon 2004-04-25 18:02:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040422 Epiphany/1.1.12

Description of problem:
When in enforcing mode, running Mozilla/Epiphany with the latest Flash
plugin version ( stops working. If I run "setenforce 0" it
works again. I've included some output information for the
flash-files. I only tried installing the plugin locally in my home

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Flash-plugin
2. Start Mozilla/Epiphany
3. Visit website with flash.

Actual Results:  Plugin doesn't get detected, "about:plugins" yields

Expected Results:  Flash should be played, and "about:plugins" should
list the plugin as detected.

Additional info:

Relevant "dmesg" output:

audit(1082929676.973:0): avc:  denied  { execute } for  pid=2026
path=/home/jacob/.mozilla/plugins/libflashplayer.so dev=hda2
ino=245798 scontext=user_u:user_r:user_t
tcontext=system_u:object_r:user_mozilla_rw_t tclass=file

"ls -lZ" in plugin dir output:

-rwxr-xr-x+ jacob    jacob    system_u:object_r:user_mozilla_rw_t
-rwxr-xr-x+ jacob    jacob    system_u:object_r:user_mozilla_rw_t
Comment 1 Jacob Kroon 2004-04-26 14:19:32 EDT
I actually solved this in an ugly temporary way, by placing the
flash-files in my $HOME/temp, and then creating symlinks to these
files in $HOME/.mozilla/plugins/
Comment 2 Daniel Walsh 2004-04-28 15:20:12 EDT
/usr/bin/epiphany-bin	--	system_u:object_r:mozilla_exec_t

needs to be added to file context.  I will add it to next policy.

chcon -t mozilla_exec_t /usr/bin/epiphany-bin


Note You need to log in before you can comment on or make changes to this bug.