Bug 121715 - RHGB switches to detailed mode when the init process starts
RHGB switches to detailed mode when the init process starts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 14:03 EDT by Mikael Carneholm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 12:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikael Carneholm 2004-04-26 14:03:41 EDT
Description of problem:
The subject line says it all: rhgb starts in suppressed mode, then
switches to detailed mode when the init process starts

Version-Release number of selected component (if applicable):
0.11.2-6

How reproducible:
Always

Steps to Reproduce:
1. Boot the machine with rhgb passed to the kernel
2. Watch rhgb start with details hidden
3. As init starts (for me, starting runlevel 5), rhgb switches to
detailed mode
4. Done
  
Actual results:
Details are shown

Expected results:
Details should remain hidden

Additional info:
Note that no errors are encountered (as this otherwise brings rhgb
into detailed mode)
Comment 1 Alan Cox 2004-05-02 19:28:58 EDT
I also see this.
Comment 2 Daniel Veillard 2004-09-15 13:51:48 EDT
Was that on a really slow machine ? 
I slightly modified how all this worked in rhgb-0.13.1 (being
pushed to rawhide) and made sure rhgb returned to non-detailed 
view as soon as the initscripts are making progresses.

Daniel
Comment 3 Mikael Carneholm 2004-09-15 15:39:08 EDT
My machine is a 2.4Ghz celeron /w 512 Mb PC3200 RAM. Not really a
snail, nor a hare.
Comment 4 Daniel Veillard 2004-09-16 02:00:11 EDT
Are you seing the issue with fedora devel ?

Daniel
Comment 5 Mikael Carneholm 2004-09-16 05:56:29 EDT
I have FC2 here with packages updated from the base, updates-released,
and freshrpms channels only (not including the development channel).



Comment 6 Matthew Mott 2004-10-08 06:33:29 EDT
I have seen this also - it has not happened for a while (FC2 with
updates), but previously the Details mode would open for no apparent
reason during bootup. IIRC it was during the "Starting networking"
phase that it would happen.
Comment 7 Kyriakos Sidiropoulos 2006-05-07 09:56:33 EDT
FC5 here. Bug still there (rhgb-0.16.3.1).
Comment 8 Ray Strode [halfline] 2007-03-28 12:21:34 EDT
So what's going on is, rhgb will automatically go to detailed mode if a service
seems to be taking too long to start.

Note we no longer wait for gdm to start before exiting rhgb, so the original
problem should be fixed.

Any other problems that come up, probably need to be fixed by the individual
services.

Note You need to log in before you can comment on or make changes to this bug.