Bug 1217178 - convert fails on monochrome XPM image
Summary: convert fails on monochrome XPM image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-29 17:31 UTC by Göran Uddeborg
Modified: 2015-11-26 20:56 UTC (History)
3 users (show)

Fixed In Version: ImageMagick-6.9.1.3-0.beta.4.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-26 20:56:41 UTC


Attachments (Terms of Use)
Image triggering this problem. (1.10 KB, image/x-xpixmap)
2015-04-29 17:31 UTC, Göran Uddeborg
no flags Details

Description Göran Uddeborg 2015-04-29 17:31:35 UTC
Created attachment 1020284 [details]
Image triggering this problem.

Description of problem:
When trying to build mj for rawhide, which includes a use of the program "convert", I get this error in the log:

+ convert WD.xpm -fill chocolate3 -opaque ivory ./--.xpm
convert: not enough pixel data `WD.xpm' @ error/xpm.c/ReadXPMImage/475.
convert: no images defined `./--.xpm' @ error/convert.c/ConvertImageCommand/3212.

(https://kojipkgs.fedoraproject.org//work/tasks/9340/9599340/build.log)

Version-Release number of selected component (if applicable):
ImageMagick-6.9.1.2-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. convert WD.xpm -fill chocolate3 -opaque ivory ./--.xpm

Actual results:
The above error message

Expected results:
A generated file "--.xpm", appropriately recolored.

Additional info:
I can reproduce it in a local mock environment.  It does seem to be connected to this particular image.  Other formats, or other images in XPM format works.  But reading this XPM format fails.  Also a simple "convert WD.xpm WD.png" fails with the same error message.

The image happens to be monochrome.  I'm guessing that is related, but of course, it might be a false lead.  I'm attaching the WD.xpm file.

When I run it in my regular environment using ImageMagick-6.8.8.10-9.fc22, the commands work as expected.
ImageMagick-6.8.8.10-9.fc22.x86_64

Comment 1 Göran Uddeborg 2015-05-04 21:05:50 UTC
I tried your updated ImageMagick-6.9.1.2-2.fc23.x86_64, but it didn't help against this problem.

Comment 2 Göran Uddeborg 2015-05-05 06:35:17 UTC
If you believe this to be a problem in the upstreams ImageMagick and unrelated to the packaging, let me know and I'll make a report in whatever they use.

Comment 3 Jan Kurik 2015-07-15 14:13:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Comment 4 Pavel Alexeev 2015-11-08 19:45:53 UTC
Thank you very much for the bugreport and willing make free software better.
That issue reported to upstream authors - http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=28649
I'll try follow fixes and push updates when it will be resolved.
And sorry for so late response.

Comment 5 Fedora Update System 2015-11-21 21:18:38 UTC
ImageMagick-6.9.1.3-0.beta.4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e125200b9f

Comment 6 Fedora Update System 2015-11-22 14:24:50 UTC
ImageMagick-6.9.1.3-0.beta.4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ImageMagick'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e125200b9f

Comment 7 Fedora Update System 2015-11-26 20:56:38 UTC
ImageMagick-6.9.1.3-0.beta.4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.