Bug 1217594 - PackageKit ignores excludes in yum.conf
Summary: PackageKit ignores excludes in yum.conf
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-30 18:29 UTC by Greta Watson
Modified: 2015-07-19 15:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 18:47:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Greta Watson 2015-04-30 18:29:18 UTC
Description of problem:
PackageKit does not exclude packages listed in /etc/yum.conf


Version-Release number of selected component (if applicable):
PackageKit-1.0.4-1.fc21.x86_64

How reproducible:
Add a package or packages to /etc/yum.conf:
exclude=dracut dracut-config-rescue dracut-network

Steps to Reproduce:
1.  Downgrade packages, such as dracut, dracut-config-rescue dracut-network
2.  Add those packages to yum.conf as excludes
3.  Reboot
4.  as root, yum update.  Excluded packages are not marked for update.
5.  Apper (KDE front end to PackageKit) shows updates available, and will
    actually update the unwanted packages unless one explicitly unchecks them.

Actual results:
    If there are updates available to files listed as excluded in
    /etc/yum.conf, the packages are updated.


Expected results:
    Don't update packages that are excluded in /etc/yum.conf


Additional info:
    I had to uninstall apper to stop the little gear icon from appearing all
    the time on my panel,which means I have to remember to use yum from the
    command line periodically to see what's new.

Comment 1 Rex Dieter 2015-04-30 18:47:36 UTC
Unfortunately, starting with f21, PackageKit's new backend functions independantly of yum (and dnf).

In short, your expectations (that PackageKit should continue respect yum.conf) cannot be met any more.

Comment 2 Greta Watson 2015-04-30 20:49:42 UTC
So, how does PackageKit exclude packages to be updated?

Comment 3 Rex Dieter 2015-04-30 20:57:26 UTC
That's a good question (I don't know), one better asked in a more appropriate venue (not a bug tracker):
https://fedoraproject.org/wiki/Communicating_and_getting_help

Comment 4 Milos Jakubicek 2015-07-19 15:57:47 UTC
What fortunately still works is if you place the exclude directive into individual .repo files under /etc/yum.repos.d/


Note You need to log in before you can comment on or make changes to this bug.