Bug 12177 - Receive Frame Errors on ppp0
Receive Frame Errors on ppp0
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-12 21:47 EDT by dadarden
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-19 13:30:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dadarden 2000-06-12 21:47:29 EDT
The serial port of the HP Brio BA 200 generates receive frame errors at a 
rate severe enough to make the ppp0 connection fail at speeds over 58K 
(15% to 30% receive frame error rate as reported by ifconfig).  The error 
rate is less severe at lower speeds, but is still evident at a 1% to 2% 
rate at 14.4K.  See Red Hat Service Request Number 145382 for workarounds 
that have already been tried.  The problem is evident on two separate new 
Brio BA200 PC's.  One has a 433 Celeron and the other a 466 Celeron.  Both 
use the i810 chip set.  The symptoms are evident under Red Hat 6.1, 6.2, 
and Suse 6.4.  The Red Hat 6.2 Retail version has been upgraded to the 
2.2.14-12.i686.rpm kernel upgrade.  Almost identical symptoms are reported 
by another user in a Linuxcare post for an Intel SE440BX-2 motherboard 
with a different chip set (see http://lc.experts-
exchange.com/Computers/Networking/Linux/Q_10361018.html).....  The 
external modem works error free on an old Gateway 2000 Pentium 60 on RH 
Linux 6.1 (retail version with no upgrades) used to IP masq a local 
network.  The serial port also works fine at high speed under Windows with 
no equipment changes.
Comment 1 dadarden 2000-07-19 13:30:14 EDT
I finally got to the bottom of the problem with help from Red hat support -- 
see Red Hat service request number 145382 for a complete history.  The problem 
appears to be an OEM hard drive made for HP by Seagate.  When I use the Seagate 
OEM drive on an Intel CA810EAL motherboard I have the problem (although less of 
a problem than when using the HP motherboard; apparently the Intel board has 
better PCI/IDE interrupt timing specs, but still not good enough to eliminate 
the problem completely).  When I use a WD136AA retail drive with the Intel 
motherboard the problem goes away (I'd test the WD drive on the HP motherboard 
but the HP BIOS won't handle the WD drive).  This appears to be a kernel 
problem involving a marginal OEM hard drive and perhaps a marginal OEM 
motherboard in the HP Brio BA200, not a ppp problem.  Based on the symptoms, I 
suspect a race condition involving PCI/IDE interrupt timing.  In addition to 
the high speed serial errors the Brio generates "unexpected interrupts" 
and "drive reset" errors whether or not I use the serial port.  In essence the 
Brio BA200 is bad news for the current Linux kernel and needs to be on the list 
of non-compliant hardware.  Apparently the Brio works in Windows because 
Windows uses the DMA channel, avoiding PCI/IDE interrupt contention.  Since the 
Linux kernel in its current release does not use DMA(?) all hard drive and CD 
traffic has to be handled through IDE interrupts, and apparently certain OEM 
hard drives and/or motherboards generate race conditions in that environment.
Comment 2 Nalin Dahyabhai 2000-09-12 15:18:04 EDT
I'll mark this as "deferred" and assign it to the kernel component then.
Comment 3 dadarden 2000-09-12 19:04:56 EDT
I'd like to request that you at least show the HP Brio BA 200 as non-Linux 
compliant hardware on your web site.  It is not compliant at the kernel level, 
and probably has PCI/IDE race conditions that put users at risk of data 
corruption, not to mention ppp problems.  I wouldn't ask, except that their web 
site shows that this model works fine with Linux and they won't even 
acknowledge my messages to the contrary.  I suffered through hours of 
troubleshooting to find their problem after being lied to by their web site 
marketing and ignored by their product support (not to mention that their 
duplicity occupied Red Hat support for some of those hours).  At least Red Hat 
might be able to keep someone else from suffering the same fate.  
Comment 4 Nalin Dahyabhai 2000-09-13 11:35:28 EDT
I'm going to follow this one up with the web team.

Note You need to log in before you can comment on or make changes to this bug.