Bug 121779 - Since openoffice.org-1.1.0-15 spelling checks seem to be broken for languages other than english and italian
Since openoffice.org-1.1.0-15 spelling checks seem to be broken for languages...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
http://www.vt100.nl/brokenoo.png
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 15:05 EDT by Rubin Simons
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 09:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rubin Simons 2004-04-27 15:05:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
Since the update of openoffice.org-1.1.0-15, the dictionaries for any
language other than english and italian seem to be missing. Because of
this the spellig feature doesn't work for anything but english and
italian. 

After a couple of days openoffice.org-1.1.0-16 came out and this is
when I first noticed the problem. I know it exists since
openoffice.org-1.1.0-15 because after verifying that it didn't work in
the latest version, i checked it on a non updated computer (which ran
openoffice.org-1.1.0-15) and saw the same behaviour. 

A fresh fedora install that never ran up2date works fine
(openoffice.org-1.1.0-6) HOWEVER "rpm -e openoffice.org
openoffice.org-libs openoffice.org-i18n" and then re-installing these
older versions on a system that did have either the -15 or -16
releases installed, does _NOT_ work; the behaviour stays the same.



Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-16

How reproducible:
Always

Steps to Reproduce:
1. update to openoffice.org-1.1.0-16
2. log in as a dutch guy by choosing the appropriate language at login
3. try checking your dutch documents' spelling in oowriter...
    

Actual Results:  I can only choose from 

English (GB)
English (US)
Italian 

languages; no dutch in sight, which used to be standard, if you logged
in as a dutch person. i tried this for other languages as well, same
results.

Expected Results:  I want to check my document in the spelling of the
language I am using.

Additional info:

This problem is pretty showstopper for most of the regular users; What
is particulary eery is the fact that installing an older version of
the package does not undo the nasty behaviour, as I would expect.
Comment 1 Rubin Simons 2004-04-27 15:08:21 EDT
A picture of the behaviour can be found at

http://www.vt100.nl/brokenoo.png

Comment 2 Dan Williams 2004-04-28 09:47:59 EDT
OOo for FC1 never actually included any dictionaries other than
English and Italian...  so I'm not quite clear on how you got Dutch to
work in the first place.  If you installed the dictionary yourself,
OOo version upgrades _do_ replace the
/usr/lib/openoffice/share/dict/ooo/dictionaries.lst file, so you may
need to re-add the dictionaries you downloaded.  If you check that
file and it still contains "nl NL nl_NL" or some such line, and OOo
still doesn't work for Dutch, then its a bug...

Could you paste the contents of your
/usr/lib/openoffice/share/dict/ooo/dictionaries.lst into this bug
report, and also tell me what files are in the
/usr/lib/openoffice/share/dict/ooo/ directory?

Thanks!
Comment 3 Rubin Simons 2004-06-04 08:16:42 EDT
My excuses; you are right. I was confused. The dictionaries where
user-installed. And I noticed that FC2 includes the dictionaries in
openoffice.org-i18n!

You can close this. my bad.

Kind regards,

Rubin.
Comment 4 Dan Williams 2004-06-04 09:21:46 EDT
no problem.

Note You need to log in before you can comment on or make changes to this bug.